View Full Version : Ultimate Fade-In, v1.51, Some new images won't display

10-02-2011, 01:32 PM
1) Script Title: Ultimate Fade-In Slideshow (v1.51)

2) Script URL (on DD):
(This is v2.4, not v1.51. I couldn't find my rev.)

3) Describe problem:
Bear with me. I'm new to this stuff.

I'm changing the images to be displayed in the slideshow.

fadeimages[0]=["http://www.uuccpf.org/wp-content/themes/starkers/style/images/1.jpg", "", ""] //plain image syntax

I changed the pictures to be displayed by actually changing the image file.
I kept the same file name (in the code) to load (1.jpg,) but changed 1.jpg to a different image.

The first time I did it the new image wouldn't display. The size was too large?
I resized/cropped the image, and then it worked.

Subsequently, I changed all the new images to be used to the required size and proceeded to change them out. Some of the new images took, while others didn't. (I changed them one at a time, and when they didn't work I tried a different "new" image.)

They are all in the correct directory. I changed the names directly in the directory using Filezilla.

The images were cropped/resized using Picnik, and Picassa. Would that have anything to do with it? I checked the properties of the images. It seems like the pictures that worked had less property information available. Coincidence?

Also: what are the additional parameter space holders for in:

...images/1.jpg", "", ""] //plain image syntax

Thanks in advance,

10-02-2011, 02:04 PM
Hi Andy,

Good day!

For your issue, it's best for us to see the page where the problem is reproducible so we could try to debug from there.

Secondly, the other paramaters apart from the image's source that you're asking is:
fadeimages[0]=["path_to_image", "optional_url", "optional_linktarget", "optional_description"]

10-02-2011, 02:26 PM
Also, sounds like you may need to refresh the page and/or clear the browser's cache.

10-03-2011, 08:20 PM
Rayph, John,

The website is http://www.uuccpf.org
The slideshow is at the top of the page.
I will change out one of the images and leave the bad one in for a while, so you can see the effect. There are only 7 images, it won't take long for the baddy to show up.

The site is a Wordpress site. Hosted on a non-wordpress server (not wordpress.org or wordpress.com

When I change out the images, the bad images just display white in the browser where the picture would otherwise be. I need to reload the page for the new images to display. I'll try clearing the cache too.

I did try loading a random image that was larger than the frame, and that image displayed without shrinking, only the top left corner showed.

This leads me to think that having the exact WxH dimensions is not 100% mandatory.


10-03-2011, 10:31 PM
There is no:


on the server. It's:


Upper and lower case matter.

You can either rename the file to 18.jpg or change it in the code to upper case.

10-04-2011, 12:31 AM

Woo Hooo! That did it. I had a bunch of the new image files that had upper case extensions. I changed them to lower case and whoomp, there it is!

I expect that this is a Unix/Linux/java issue. I'll pay attention to that in the future.

The check is in the mail. I like your causes, but you decide.



10-04-2011, 01:55 AM
It's javascript, not java - two quite different languages. And it has nothing to do with either. It is a bit of a Unix/Linux thing, but more of a server thing. Almost all servers, even Windows servers distinguish between upper and lower case letters in paths and filenames. Some servers, most I think can be set to ignore case, but the default for most is to pay attention to it, and most do. On the other hand, most local machines do not distinguish and can even at times show (in their open/save dialogs and folder listings) all lower case even when some or all letters are upper case.

As for my favorite charity, I can't pick, that's why I listed 3. If you need me to name one, go with:

International Rescue Committee (http://www.theirc.org/donate/overview.html)