PDA

View Full Version : Slideshow Difficulties



shf
09-18-2011, 05:20 PM
1) Script Title: Fade-In Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem: I am trying to add fadeshow1 (no captions, simplest version) into my site - customizing it with my images.

I inserted the code and tried to follow instructions as best I could but nothing is happening when I preview it in my browser. Can you please take a look at the code for the page and my javascript (both are attached) and let me know where I went wrong?

Thank you for your help.

jscheuer1
09-18-2011, 06:52 PM
The fadeslideshowjs.txt attached to your post shows two code edits. The first of which causes a fatal error, the second of which is fine but unnecessary given the on page call shown in the other attachment.

Get a fresh copy of fadeslideshow.js from the demo page and use it.

Browser cache may need to be cleared and/or the page refreshed to see changes.

shf
09-19-2011, 03:01 AM
Thanks for the quick reply. I followed your instructions and recopied the js file without editing it but unfortunately it still didn't work.

To clarify - When I check on the status of this, I'm not uploading the changes, I'm previewing it in my browser; I'm doing this for a client so I can't yet upload the site. I cleared my browser cache anyway and refreshed - no change. But this was never an issue before in javascript for me anyway.

I attached the edited files - do you perhaps have any other thoughts? Are all my paths and folder names correct?

My images are in a folder called "images" and I didn't know if I should rename anything in the code provided.

Thanks - I appreciate your help on this.

jscheuer1
09-19-2011, 03:28 AM
I already looked at the files in detail. That was the only problem I could see, the edited fadeslideshow.js file.

We're at the point where you need to put up a demo of the problem. It can be an orphan page anywhere on the web, with only the minimum required scripts, images, and markup, it just has to show the problem.

shf
09-23-2011, 01:38 PM
Hi John,

I managed to figure out this problem and uploaded the slideshow but thank you anyway. However, my client tells me they can't view the show on an iPad or iPhone.

I specifically chose to upload a javascript slideshow instead of flash to avoid this problem. Any solution?

Thanks,

Sheira

jscheuer1
09-23-2011, 06:02 PM
I don't have a mobile device, ipad/phone to test on. I'm not aware of any inherent problem for those devices with this script. That doesn't mean that there aren't. It's my understanding that those devices do not support mouseover/mouseout events. But I don't think that would prevent the slideshow from appearing. As a test have them try the demo page on Dynamic Drive in their iWhatever. If that works, it's something with your implementation. If not, I have an idea for a mod that may take care of it.

Please note though, these are free scripts and the script is not rated for mobile devices.

It's always possible to not serve it to those devices, offering instead alternative content. Or one could find a (probably simpler) sort of gallery that works for all and just use that.

You could even go back to Flash, serving iDevices something else (quicktime?) that they can handle.