PDA

View Full Version : Resolved Z-index problem with Ultimate Fade-in slideshow



Paramasivan
09-16-2011, 09:47 PM
I am using jQuery Multi Level CSS Menu #1 and just below it Ultimate Fade-in slideshow.

I put z-index:1000; for .jquerycssmenu ul li ul li
and changed z-index at several places of fadeslideshow.js.

Also put inline style of <div id="fadeshow1" style="z-index:0;"></div>

But still the sub menus of multi level menu are not appearing in ie 6 and ie7.

Any help?

jscheuer1
09-16-2011, 11:30 PM
I wouldn't mess with the zIndex in the fadeslideshow.js script. It's too complicated, changing up and down as required to fade one image over another, not to mention the descriptions if used showing over all of that.

Instead, just set the menu's z-index to 2000, plenty more than anything the slideshow uses. However, it is possible in older IE that this will not be enough. If not, please post a link to your page. It can be worked out.

Also, please link to the demo page here on Dynamic Drive for the specific menu you're using.

Paramasivan
09-17-2011, 12:07 AM
Site is under development and not yet hosted.

I am using jQuery Multi Level CSS Menu #1

I set the z-index of of menu to 9000 and even then ie6 and ie7 are showing trouble.

jscheuer1
09-17-2011, 12:53 AM
Please link to the demo page here on Dynamic Drive for the specific menu you're using.

Paramasivan
09-17-2011, 01:00 AM
http://www.dynamicdrive.com/style/csslibrary/item/jquery_multi_level_css_menu_horizontal_blue/

jscheuer1
09-17-2011, 02:42 AM
On a default install of the two scripts, all that's required is that in the jquerycssmenu.css file add the highlighted as shown (around line #18):


/*Top level list items*/
.jquerycssmenu ul li{
position: relative;
display: inline;
float: left;
z-index: 2000;
}

Demo:

http://home.comcast.net/~jscheuer1/side/jq_css_mnu/test.htm