PDA

View Full Version : Lightbox Display Issue



sketstu1
07-05-2011, 12:07 PM
Hi everybody, just wondering if any one might to be able to help with a problem I am experiencing with lightbox. Currently, I am using the 4Level extension for dreamweaver, to add lightbox to a simple image gallery.

The light box appears to be working fine, except, if an image or images are clicked and then closed rapidly before they have finished loading in lightbox, all other images are not displayed correctly in lightbox(image and caption are dis-jointly displayed etc). Only refreshing the page will correct the issue.Sorry if this sounds rather complicated I have tried to explain as much as possible.

The image gallery(only an example) can be found here:

http://www.andrewmatthewspainting.co.uk/lightbox.html

Many thanks for any help!

jscheuer1
07-05-2011, 07:35 PM
That's a known issue with Lightbox. Or at least it was. I see you're using version 2.03.3 of Lightbox. I might try version 2.05 or whatever is the latest:

http://www.lokeshdhakar.com/projects/lightbox2/

But that issue may or may not have been worked out.

And Lightbox is rather a bloated program for what it does. Slimbox 2:

http://www.digitalia.be/software/slimbox2

would be what I would use if all I wanted was the Lightbox effect. Slimbox 2 claims to have fixed that very problem you mention:



Slimbox is more responsive; it allows you to close it immediately at any time using the keyboard or mouse and to instantly navigate to any image before the current image has loaded or the animations are complete.


The script is more robust; for example you can try to start and stop Slimbox or navigate between images very quickly to interrupt the animations and resume them and you won’t notice any bug like in the original Lightbox where sometimes the animation stops or the elements are wrongly sized or positioned.

sketstu1
07-05-2011, 09:28 PM
Great stuff....exactly what I was after, many thanks.