PDA

View Full Version : Fade slideshow js conflict in IE9



mancub
06-30-2011, 03:02 PM
1) Script Title: Ultimate Fade-in slideshow (v2.4)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem:
I am building a site http://www.kineticsmartialarts.com/
This uses Dynamic Drive's "fade slideshow" listed above and also "buildinternet's" "Supersize Core 3.1.3": http://buildinternet.com/project/supersized/demo.html

My site works fine in every browser but IE. (I'm running IE9). Chrome, safari, firefox all display both the supersize background and the fade slideshow - both scripts working perfectly. IE only displays the background, the slideshow fails to work. (The demo of the slide show at DD works fine in IE9 and I have used it successfully in other sites.)

I have tried changing doc types but to do avail (clutching at straws - and straws that I don't fully understand for that matter!). I'm farely new to websites and on a steep learning curve so any help or advice on how to correct the issue (or why it might be specific to IE) would be much appreciated. Mostly as I don't want to compromise the design, but don't want to alienate 45% of browser users.

jscheuer1
06-30-2011, 03:28 PM
Get rid of this:


<meta http-equiv="X-UA-Compatible" content="IE=8" />

It's not doing anything anyway, it's in the wrong place.

Update to jQuery 1.6.1, change this:


<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.5.0/jquery.min.js"></script>

to:


<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.1/jquery.min.js"></script>

That's all it took to fix things here in a local mock up. First thing I tried.

mancub
06-30-2011, 03:46 PM
John,

I take my hat off to you sir! Works perfectly.

As you probably have guessed I'm something of a cut and paste man at the edges of my knowledge - the "<meta http-equiv..." was actually left over from "buildinternets" supersize demo file.

Thanks again for your help.