PDA

View Full Version : Smooth menu broken in IE8?



avittech
06-23-2011, 06:06 AM
1) Script Title:
Smooth Navigational Menu (v1.5)

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm#ajax

3) Describe problem:

very odd problems
in my page ff 3.6.18 will not run the script correctly, the motion works, sub menu pops up like a champ. but the other 1st level links do not work or highlight. This could be something I did to break it as it works on the demo page with the same browser.

the part I don't get it in explorer 8 the sub menus stay open when activated, everything else works correctly even top level menus (why my page works better in ie but not FF is beyond me), and to top it off I get the same result on the DD page, the sub menus stay open when activated.

any ideas?

my only modifications to the script was in the css, just setting colors and margins. The div containing the ul code is nested in a couple divs, but still behaves the same if i put it all by itself outside of the divs.
I only have the init for the part I use (horizontal).
I have the container div with the ul in an external php file (php only in title) that gets called by the main page

tried the ajax method but the menu didn't even display when I tried that. (made all necessary modifications to the init section)

avittech
06-28-2011, 01:36 PM
well, I discovered the issue with IE8
seems the divx plugin was breaking java in general, so an update corrected the problem.
however I'm still having some issues under FF where the submenu pops just fine, but the 1st level links dont highlight or link when clicked on.

assuming I messed something up in the edits I made for the time being