PDA

View Full Version : Images not positioned correctly with glider



jend70sugar
05-26-2011, 07:39 PM
1) Script Title: Featured Content Glider

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/featuredcontentglider.htm

3) Describe problem: I've noticed that my images for the glider are off to the side just a litte bit, and in IE 7 they are WAY off to the side. What could be causing this? I've looked through the code and everything seems ok but i'm still kind of new at html and i'm just maintaining the website. Please any help would be great!

jscheuer1
05-26-2011, 08:49 PM
I removed the link to your website because it went to some generic 'register this domain' page. Either you mistyped it or there's some problem with your account and/or with your host, or there might just have been some problem with the internet.

What you're describing is often caused by using center.

This can be text-align: center; in style, the align="center" attribute, or even the <center> tag. Sometimes I see more than one or all three on a page, sometimes nested.

Anyways, that's not really the way to center things. And once you start using something like that, it can mess up features like the glider which use absolute positioning.

Often though you can fix something like the glider by just giving it text-align: left; like so in the featuredcontentglider.css file (near the top):


.glidecontentwrapper{
position: relative; /* Do not change this value */
width: 350px;
height: 230px; /* Set height to be able to contain height of largest content shown*/
border: 5px solid #687C98;
overflow: hidden;
text-align: left;
}

That should do it as long as that was the problem and you have no inline style or attributes for the glidecontentwrapper that contradict it.

If you want more help, please give us the real link to the site.

jend70sugar
05-27-2011, 05:50 PM
Thank you! that fixed it, at least for firefox and safari, I don't have IE 7 so i'm not sure if it's correctly placed there....

jscheuer1
05-27-2011, 07:09 PM
If you want me to check in IE for you, just post the link.

jend70sugar
05-27-2011, 07:14 PM
http://www.hollywoodweeklymagazine.com/

jscheuer1
05-27-2011, 07:33 PM
The 'A Century of Celebration' is a little off, kind of down and to the right.

That can be fixed by using a standards invoking DOCTYPE.

At the very top of the page, add the highlighted as shown:


<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta name="generator" content=
"HTML Tidy for Mac OS X (vers 31 October 2006 - Apple Inc. build 15.3.6), see www.w3.org" />
<meta http-equiv="Content-Type" content=
"text/html; charset=us-ascii" />
<meta name="keywords" content=
"entertainment, hollywood, magazine, Michael Jackson, movies, box office top ten" />
<meta name="description" content=
"Entertainment Magazine for Hollywood, featuring music, fashion and TV shows" />
<title>Hollywood Weekly Online</title>
<link rel="icon" href="favic . . .

jend70sugar
05-27-2011, 08:14 PM
Ok I added it, I hope that fixes the problem

jscheuer1
05-27-2011, 10:35 PM
All fixed!

jend70sugar
05-27-2011, 11:02 PM
Great thank you!!