PDA

View Full Version : Smooth Navigational Menu - CSS Issue with Apache Tiles



sam101
04-17-2011, 11:05 PM
1) Script Title: Smooth Navigational Menu

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm

3) Describe problem: I am using the above menu with Apache Tiles. We have Tiles to provide us with layout for hearder, body, and footer. Menu is our headeer, than footer we have some foot note. Body loads different content based on what user clicks on the menu.
First time when you come to page we can see menu and footer loading fine. Than when I click on some menu links, it loads the page, while loading I can see menu without css for a 2 seconds or so than css is applied to menu.

Any way to fix this. Why this happens when I click on some link to load body it. Tiles reloads the whole page, that time this happens.

It works fine in Firefox but not in IE8. :confused:

sam101
04-18-2011, 03:48 PM
Anyone

ddadmin
04-19-2011, 07:54 AM
Hmm are you essentially asking why there is always a 2 second delay before the CSS of the menu is applied to the menu when your page loads? If so please post a link to the page on your site that contains the problematic script so we can check it out.

sam101
04-19-2011, 01:46 PM
Its our internal site, noone will be able to access it. We are using this css in tiles.xml. Menu is our header, than we have body and footer.
Initially when menu loads firts time, it works fine, when we click on some Menu link than we can see non css menu for 2 sec, than it loads the menu with body content.

Anyways to delay this loading...