PDA

View Full Version : Some problems with image crawler (image gap and only one crawlbar is visible)



Kukuschi
04-04-2011, 10:10 PM
1) Script Title: Text and Image Crawler

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex2/crawler/index.htm

3) Describe problem:

1. On my site http://Buchmaler.de i have 4 of those scroll bars with different content but only one is displayed and i do not find the mistake, why the others are not displayed.

At the moment i use thickbox, too, but the same problem appeard whisthout it, too.

2. Can i change the gap between the Pics to 0 ? (Between the last and the first pic of a gallery there are two spaces instead of one between them so the gap is twice as big).



Greetings, Lars

P.S.: Sorry for my bd english skills

Kukuschi
04-05-2011, 08:37 AM
under http://www.buchmaler.de/test it is now without any other scripts. Now it is displaying the first, the third and the fourth of the galleries but not the second.
Please, i really need help on this.

<div class="marquee1" style="overflow: hidden;">
<div style="visibility: hidden; padding: 0px; height: 150px; width: 100%; position: relative; overflow: hidden;">

Firebug told me this. The problem must be "visibility:hidden"(on the other three galleries it is "visibility:visible" but i do not know how to correct it and why it only happens to this gallery.

Edit: Problem with the invisible gallery solved. The problem with the picture spacing remains.

Kukuschi
04-12-2011, 06:12 PM
Nobody any idea concerning the double space between last and first pic?:(

jscheuer1
04-12-2011, 07:33 PM
Use the noAddedSpace: true, property, ex:


marqueeInit({
uniqueid: 'laufband2',
style:
{
'padding': '0px',
'height': '150px'
},
inc: 20,
mouse: 'cursor driven',
stopped: true,
noAddedSpace: true,
moveatleast: 0,
neutral: 150,
savedirection: true,
});

But that appears to remove all space. I added a little back by giving the first image a margin-left of 0.25em:


<div class="marquee" id="laufband2">

<a href="/images/gallery/014.jpg" rel="example3" title="014">
<img src="/images/gallery/014thumb.jpg" border="0" style="margin-left:0.25em;">
</a>

<a href="/images/ga . . .

Ordinarily that doesn't happen. That space should be added and should be the same as the spaces between the other images that are caused by the CR/LF breaks and/or space characters between them in the HTML markup source code. Perhaps something about your other styles is enlarging it. If it is though, I can't easily find it. The cause might be something else.

Kukuschi
04-12-2011, 10:26 PM
Ahh thx :)