PDA

View Full Version : Ultimate Fade In Slideshow



wtaggin
04-04-2011, 03:36 PM
We just started experiencing hover issues with the new IE9 out...our URL is http://www.skydivegeorgia.com/...

I am no JS expert, but it seems like the pause effect / mouse effect on hover is causing an issue with IE9. I cannot find out what is causing this, as it ONLY happens in IE9 (go figure.) Works fine in Chrome, FireFox 4, and IE8 / IE9 Comp. Mode.

Any guidance / help would be greatly appreciated.

Thanks, in advance.

jscheuer1
04-05-2011, 05:03 PM
You have a lot going on with that page. Are you 100% sure it's the UFade script?

Anyways, first thing I would try is updating to the most recent version of UFade:

http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

It uses jQuery and is compatible with the version of jQuery already in use for that page. So you should skip this (from the first code block on the demo page):


<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>

And in the script itself (fadeslideshow.js), since your other jQuery code isn't in NoConflict mode, comment out (red) that line (highlighted) near the beginning of the script:


/* Ultimate Fade-in slideshow (v2.4)
* Last updated: May 24th, 2010. This notice must stay intact for usage
* Author: Dynamic Drive at http://www.dynamicdrive.com/
* Visit http://www.dynamicdrive.com/ for full source code
*/

//Oct 6th, 09' (v2.1): Adds option to randomize display order of images, via new option displaymode.randomize
//May 24th, 10' (v2.4): Adds new "peakaboo" option to "descreveal" setting. oninit and onslide event handlers added.

var fadeSlideShow_descpanel={
controls: [['x.png',7,7], ['restore.png',10,11], ['loading.gif',54,55]], //full URL and dimensions of close, restore, and loading images
fontStyle: 'normal 11px Verdana', //font style for text descriptions
slidespeed: 200 //speed of description panel animation (in millisec)
}

//No need to edit beyond here...

//jQuery.noConflict()

function fadeSlideShow(settingarg){
this.setting=settin

Otherwise, just follow the installation instructions on the demo page. Oh, and be sure to remove the older version!