PDA

View Full Version : Need help with lightbox 2.04 and IE



downtown
03-01-2011, 06:37 PM
1) Script Title: lightbox2.04

2) Script URL (on DD): http://www.dynamicdrive.com/forums/showthread.php?t=49527




3) Describe problem: In IE the lightbox opens not in the middle also the background doesn't cover the whole browser window. With the images
there is also a problem that the white frame is too big only at "bild10"
it fits. Any suggestions what goes wrong here? In FF everything fits.

This is the site: http://www.styling-food.de/test2/fisch.html

Thank & Regards
downtown

SillyoldDuffer
03-02-2011, 12:35 AM
Ok I just viewed using IE6/7/8 and it looks as it should be:) dont use IE9 yet so cant say...to fix the background not filling the whole page you can try this, In the lightbox css file you will see the code below this should fix what you mentioned but I cannot say what maybe wrong as it looks ok to be in the browsers I tested with...

Before

#overlay{
position: absolute;
top: 0;
left: 0;
z-index: 90;
min-width: 100%;
height: 500px;
background-color: #000;
}

After

#lbOverlay {
position: fixed;
z-index: 9999;
left: 0;
top: 0;
width: 100%;
height: 100%;
background-color: #000;
}

downtown
03-02-2011, 05:32 AM
Hi,
thanks for your suggestions..I tried it and the background fills the whole
browser window...great!:). But the problem with image container still exists.
When you have the time to look at it you will see that for example the image
with the spoon (second picture), the white surrounding framing is bigger as
on the 3th. picture with the pan and the three shrimps. Do you have any idea
to fix this...I will try now @work maybe my IE6 is to old;-))

Thank you very much.

Regards
downtown

downtown
03-02-2011, 10:12 AM
Hi,
seems that when I work local on the site I get this strange layout problems.
Because when I go to the page on the internet, the script warning doesn't appear. When I work local I have to admit the script first otherwise the site is blocked by IE. Do you know, how I can get rid of this behaviour?

I've tested the page on the internet with IE7/8 and FF and as you say it looks
normal. No strange framing or background problems. I think I hate IE.;-))

Regards
downtown