View Full Version : Resolved Javascript conflict, but works fine in firefox 3.6

03-01-2011, 01:25 AM
Hi all,

quite a while ago I posted on the DD forums about a problem I've had with 2 scripts (both from here) conflicting with each other. The conflict is between Drill Down Menu (v1.6) (http://www.dynamicdrive.com/dynamicindex1/drilldownmenu.htm) and Dynamic Ajax Content (http://www.dynamicdrive.com/dynamicindex17/ajaxcontent.htm).

I use the Drill Down Menu system to load dynamic ajax pages.
This all works fine on Firefox 3.6 but when I try another browser the Ajax pages fail to load and in Internet Explorer 8 an error appears in the bottom status bar saying "'document.getElementById(...)' is null or not an object".

When I last posted about this I was told that IE cannot handle global variables with the same name as an DOM element ID, especially if that variable is actually pointing at that DOM node and that I should try changing the id to something else and maybe it will work. But I never did figure it out as I'm quite a noob at javascript.

I originally thought the problem only happened in Internet Explorer but I've found it also happens in Google Chrome and Firefox 4.0 beta versions.

I am desperate to get this working and I'm prepared to pay for a working solution. The webpage is http://woodenboatshop.com.au/yanmar/spareparts.php

03-03-2011, 05:12 AM
110 views and nobody has any clue? Please guys I really need help with this, someone must know. :(

03-08-2011, 05:49 AM
Still nothing at 275 views. Even when money is offered for a solution.
I'm really desperate for a fix here :(

03-30-2011, 02:08 AM
It is unfortunate that I never got a response, with the release of Firefox 4 I found that it no longer worked properly in Firefox (as expected) so I had to change my menu system to a completely different script to make it work.

I guess that means this can be labeled as solved even though it technically was not.

EDIT: How do I mark it as SOLVED? Thought it would be under thread tools but can't see it :/

03-30-2011, 03:06 AM
Edit (in advanced mode) and select "Resolved" from the prefix dropdown menu.

03-30-2011, 05:16 AM
Edit (in advanced mode) and select "Resolved" from the prefix dropdown menu.

It won't let me edit the initial post at all even though it is my own, the button isn't there.

03-30-2011, 08:49 PM
There is a time limit for editing posts. If you can't edit the post, you can ask a moderator to do it for you. I've now marked this as resolved. In general, it's helpful if you can mark it resolved, but if the edit time has passed, don't worry too much about it. That's not your fault obviously.
(Note: the edit time limit exists because otherwise spammers could go back and add spam links to old posts without anyone ever seeing it; and it also is good to post a new reply so people will know there's new information if it has been a significant amount of time.)