PDA

View Full Version : Tooltip V2.0 Not Working



Steve S
02-24-2011, 07:51 AM
Image With Description Tooltip v2.0

http://www.dynamicdrive.com/dynamicindex4/imagetooltip.htm

Can anyone help me get this script to run?

Iím trying to use the Image With Description Tooltip v2.0, but it refuses to work for me. My JS skills are almost zero so I wouldnít be surprised if itís due to something very simple.

At first I tried to build it into an existing page but I couldnít seem to get it working.

Now Iíve built a simple page with no formatting and only four text links on it. The page, JS and CSS files and four JPEG pictures are all in the same folder. The only changes that Iíve made have been to change the picture file names in the JS file to match my pictures. Yet still I canít get it to work.

Page: http://www.wildsight.co.uk/testing/test3.html
JS: http://www.wildsight.co.uk/testing/ddimgtooltip.js
CSS: http://www.wildsight.co.uk/testing/ddimgtooltip.css

Any help or advice would be most appreciated.

Thanks.

Steve.

azoomer
02-24-2011, 11:50 AM
You have some line beaks in the ddimgtooltip.js file that causes the malfunction.
Compare each line with the original (http://www.dynamicdrive.com/dynamicindex4/ddimgtooltip.js) and you should be able to make it work.

Steve S
02-24-2011, 01:05 PM
Thanks a million. :):):)

I copied the layout of the original exactly and, as you say, it now works fine.

It seems as if my editor modified the line breaks when I opened up the file after downloading it, and in my utter ignorance, made a fool of me.

I'll have to keep a lookout for that in future. :o

Steve.