PDA

View Full Version : simple gallery and facebook connect



timondeks
02-18-2011, 03:49 PM
1) Script Title:
Simple Controls Gallery v1.3
2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex4/simplegallery.htm
3) Describe problem:

I'm using the simple gallery script on the home page that also includes a wordpress blog. The problem Iam having is that when someone selects the link to the single blog post with comment box the simple gallery banner no longer shows, just a white background. I think the problem is caused by the facebook comment box plugin as the galery works fine with the default wordpress comment box. Im not sure how to fix the problem but can I set a background image for the simple gallery script so at least there is an image instead of a white box. Long story short is it possible for me too set a background image for this script?

site add is: www.rentafriend.ie/wordpress

timondeks
02-22-2011, 10:57 AM
bump dee bump dee bump

SillyoldDuffer
02-22-2011, 04:00 PM
Are you using more than one version of jQuery in the same page? I have noticed in your source that the simple gallery is using jquery-1.2.6.pack.js and wp-includes/js/jquery/is using 1.4.2 this will more than likely be the cause as both scripts are getting called at the same time and then causing a conflict you can try adding this into between the <head></head>tags
<script type="text/javascript">
jQuery.noConflict();
</script>

timondeks
02-24-2011, 01:35 PM
Thanks for the reply. As far as I know there's only the one version jquery on the page. The only other dynamic content is the twitter/FLIKR feeds and wordpress. I tried adding the noconflict lines but alas the banner still shows up blank white

timondeks
02-25-2011, 02:38 PM
Is it possible to set a background image for the script itself? I tried setting the background of the div positioning the simple gallery but it still shows a white background on page reload

timondeks
03-01-2011, 09:09 AM
bump bump bump bump

SillyoldDuffer
03-02-2011, 01:08 AM
Ok like yourself I am a Junior coder..but looking at your page source and looking at the Gallery script I saw this....
persist: false, //remember last viewed slide and recall within same session?

Maybe try setting to persist: true,

timondeks
03-06-2011, 02:41 PM
Cheers for the suggestion SillyoldDuffer, unfor still get the same blank gallery

azoomer
03-06-2011, 04:52 PM
Try using the simplegallery.js file that jscheuer1 is linking to in this thread. (http://www.dynamicdrive.com/forums/showthread.php?t=58889)
It is a noConflict version of the same script. It is needed because the facebook script is in jQuery.noConflict mode. Hope that works.

timondeks
03-09-2011, 12:28 PM
Thx fo the help azoomer, I uploaded the no-conflict version but still no luck, jscheuer1 mentioned re-ordering the scripts, would this maybe be necessary with the facebook script?

azoomer
03-09-2011, 04:17 PM
To bad. I thought I had it figured out. Actually had your page working fine on my pc with the noConflict version on the script ? Mysterius. It's not a bad idea to reorder the scripts and see if that works better, but you may want to make a backup before you change anything. I was playing with the css now and if i add this rule


#simplegallery1 {
background: transparent !important;
}

a background image appears. You can try it out.