PDA

View Full Version : simplegallery.js IE8 vs Mozilla



psoilcoil
02-07-2011, 06:19 PM
Hi all,
I have just created a page to share pictures

1) Script Title:
Simple Controls Gallery v1.3


2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex4/simplegallery.htm

3) Describe problem:
IE8.0 can not process the script

I have just created a page to share pictures
http://www.best-places-bulgaria.com/melnik-pyramids-pictures.html
by using the simplegallery script

However my IE8.0 can not process the script. Mozilla, Safari and Chrome do not have any issues with it.

The generated error is
Webpage error details
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.6; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Mon, 7 Feb 2011 18:37:08 UTC
Message: 'imagearray[...].0' is null or not an object
Line: 34
Char: 3
Code: 0
URI: http://www.best-places-bulgaria.com/support-files/simplegallery.js
Message: Object required
Line: 453
Char: 26
Code: 0
URI: http://www.best-places-bulgaria.com/support-files/main.js



Could you please help me understand the problem? What do I have to change in order to make IE process the script?


Thank you

azoomer
02-07-2011, 06:41 PM
one error that can prevent IE from working is an extra comma after the last image in the image array. Remove the red comma


["http://psoilcoil.powweb.com/images/imgP1040382_melnikgal.jpg", "", "", ""],

(see the documentation (http://www.dynamicdrive.com/dynamicindex4/simplegallery.htm))

I don't understand the other error in the main.js, but as the page is right now I can't see that main.js is being used for anything, so maybe you could just delete it!

xxTTcc
03-04-2011, 11:06 AM
Оправи ли си проблема, защото гледам имаш същия проблем като мен а никой не е отговорил, затова ще си пиша на български.

Translation (Google Translate):

"Okay my problem, because you see the same problem as me but no one answered, so I will write in Bulgarian."

xxTTcc
03-04-2011, 11:51 AM
Hi I am bulgarian but it seem that we can not write in bulgarian here. Do you have a solution of your problem. Because I have one for you. Just tell me if you are using php to generate you pictures array

jscheuer1
03-04-2011, 03:25 PM
psoilcoil's page works fine here in IE 8 (Version 8.0.6001.18702IS Build 86001 under Win XP to be exact). I guess either it was fixed, or the IE 8 used to test it was different than mine.

See azoomer's post (now merged in from psoilcoil's other thread on this same topic):

http://www.dynamicdrive.com/forums/showpost.php?p=247600&postcount=2

It may help you xxTTcc.

If not, please start a new thread for a new question and provide a link to your problem page.