PDA

View Full Version : Problem ONLY ON Internet Explorer 8!! Not showing chat bar and a form at same time!!



SamyCode
01-22-2011, 04:23 AM
Please, help me. I can't find a solution to this. I am making a webpage and, in one of my slices I have a contact form which I got from www.emailmeform.com and a chat bar which I got from www.wibiya.com. The problem is that the chat bar doesn't show in Internet Explorer 8 when there is a contact form. THE PROBLEM IS ONLY ON IE!! I attached here some example. I know that it only happens when there is a contact form because all of my other pages are working fine but the two that I have contact form on it. Sorry about my english but is not my main language. Any help would be GREATLY APPRECIATE.

jscheuer1
01-22-2011, 06:10 AM
Here's the error I'm getting in IE 8:



Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)
Timestamp: Sat, 22 Jan 2011 06:11:22 UTC


Message: '$.validationEngineLanguage' is null or not an object
Line: 768
Char: 2
Code: 0
URI: http://www.emailmeform.com/builder/js/dynamic.php?t=post&t2=0



Here's the code it's pointing to (section highlighted, line 768 red):


. . . "fname":"check_file_type",
"alertText":"* Invalid file type, allowed (jpg,jpeg,png,gif,bmp,psd,doc,docx,txt,pdf)"
}
}
}
}
})(jQuery);

$(document).ready(function() {
$.validationEngineLanguage.newLang()
});;/*
* Thickbox 3.1 - One Box To Rule Them All.
* By Cody Lindley (http://www.codylindley.com)
* Copyright (c) 2007 co . . .

If you can, change that to:


"fname":"check_file_type",
"alertText":"* Invalid file type, allowed (jpg,jpeg,png,gif,bmp,psd,doc,docx,txt,pdf)"
}
}
}
}
})(jQuery);

jQuery(document).ready(function($) {
$.validationEngineLanguage.newLang()
});;/*
* Thickbox 3.1 - One Box To Rule Them All.
* By Cody Lindley (http://www.codylindley.com)
* Copyright (c) 2007 co

SamyCode
01-22-2011, 06:32 AM
Thanks for the help man but... There's a change that, that code is in other place? Because the page with the error have only 337 lines of code and I even tried to search for the part that you mention around my code and can't find it. There's another way to work around this bug??

Thanks in advance.

jscheuer1
01-22-2011, 09:03 AM
That's right, that's not on any page you have, it's on the emailmeform.com site and it's not even a page. It's a PHP script that generates a javascript. It's not exactly a bug, more like a typo on their part.

But I think if they fixed that, there would be other errors. Here's a workaround - on register,php add the highlighted as shown:


. . . ortaje contiene un video, favor de subirlo en alguna página dedicada a esto como lo es www.youtube.com. Nos debe enviar entonces el link de donde reside su video y alguna otra explicación siempre y cuando sea necesaria.</li>
</ol>
<p>&nbsp;</p>
<p>¡No pierdas la oportunidad! ¿Estás preparado? ¡Sube tu noticia ahora!</p>
</br>
<p><link rel="stylesheet" type="text/css" href="http://www.emailmeform.com/builder/styles/dynamic.php?t=post" />
<script type="text/javascript" src="http://www.emailmeform.com/builder/js/dynamic.php?t=post&t2=0"></script>
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>
<form id="emf-form" enctype="multipart/form-data" method="post" action="http://www.emailmeform.com/builder/form/7NcMO6UX8werb2c2715H0i" name="emf-form">
<div align="center">
<table style="text-align:left;" cellpad . . .

Only thing is, though it gets rid of the error and the chat bar works, because I'm not certain what the form script does, I'm not certain if the form routines will still work. Try it out and let me know.

If not, find a form script that's better written.

SamyCode
01-22-2011, 11:58 PM
Wao u are really the man in Javascript. The contact form seems to be working fine so, thank you so much. Now I have a LAST question. I will NOT bother you any more, I PROMISE. I have an issue and is not an IE problem only but it happens in all the browsers. I have a little "chat app" in my contact page that is made for me to can offer live support in my page. I got this little application from www.meebo.com. The issue that i'm having is that if you scroll down the page, the meebo app appear to be OVER the chat bar. I include here an attached little example so u can see of what i'm talking about. This little issue is ugly so If u can help me on this... I will be gratefull forever.

jscheuer1
01-23-2011, 05:47 AM
Add the highlighted (two places) as shown (scroll to see them):


<td><div align="center">
<!-- Beginning of meebo me widget code. Want to talk with visitors on your page? Go to http://www.meebome.com/ and get your widget! --> <object width="220" height="350" ><param name="movie" value="http://widget.meebo.com/mm.swf?FfOoAmFsSb"/><param name="wmode" value="transparent"/><embed src="http://widget.meebo.com/mm.swf?FfOoAmFsSb" type="application/x-shockwave-flash" wmode="transparent" width="220" height="350"></embed></object>
</div></td>

SamyCode
01-23-2011, 07:21 AM
Very very thanks. I really appreciate it. I'm working in some good ideas and I have my people. I will remember about you.

Take care

SamyCode
02-04-2011, 06:22 AM
I have my page live already. My question now is... I already did what you told me and I add the extra line to my script. I remember that, it worked fine with your new line to the script. You remember that we were having some kind of conflict between the chat bar and the contact form script?? Well, I have another weird issue now... since yesterday, the chat bar stop working for Internet Explorer 8 but only in one of the page that didn't work before. I mean, I have one page with the chat bar and a contact form working perfect and in another page I have the same problem of before. The problem just appear since yesterday and I don't recall me making any new chances to the code.


The page that work with the contact form and the chat bar, both of them perfect is: www.newswithfreedom.com/pagina_contacto.html

The page that have a conflict problem again is: www.newswithfreedom.com/register.html

Can you notice some difference between them? What's wrong?? Sorry for the bothering but sometimes it looks like this forum is my only option. :confused: