PDA

View Full Version : Anylink CSS Menu - Long Delay in IE Page Load



pinch
12-09-2010, 08:25 PM
1) Script Title: Anylink CSS Menu

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/anylinkcss.htm

3) Describe problem:

I'm using this script in a bit of a special way in that I'm hooking up quite a few menus on a single page (roughly 88, it's a unique web application). My problem is that, in IE (IE8 with compatibility both on and off), the script is causing a loooong delay between the time the elements on the page are viewable and the time that you can actually start doing something (if you try to do anything, you just get an hourglass). In a page with 88 menus, the page elements load in about 4 seconds, but the browser stays locked for an additional 45 seconds before I can do anything.

If this were a common problem across all browsers I'd chalk it up to the fact that I'm just hooking up too many menus, but in Firefox and Chrome there is no delay whatsoever. As soon as all of the page elements are loaded, I can start working.

My page is built in asp.net, but I've loaded a demo here (http://www.cheatsheetwarroom/htmlmockups/driverTemplate/drivertemplate.html). After the page loads in IE, try to scroll. You'll see there is a delay before you can do anything. Then, try to view the page in Firefox, you can scroll immediately. The menus are generated when you hover over a magnifying glass icon.

Any Ideas

pinch
12-13-2010, 08:26 PM
The demo link has been corrected.

ddadmin
12-13-2010, 11:10 PM
Hmm the link remains broken for me.