PDA

View Full Version : Problem with Tooltip v2.0 on Secure Connection



KevScott
11-08-2010, 10:28 PM
1) Script Title: Image w/ description tooltip v2.0

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/imagetooltip.htm

3) Describe problem: using script on https page when you say to only show content that was delivered securely than get error on Webpage error details:

Message: Object expected
Line: 59
Char: 3
Code: 0
URI: https://www.mixon.com/ssl/ddimgtooltip.js

If i say show content that is not secure than it will work.

Any advise?

jscheuer1
11-09-2010, 04:23 AM
Generally all content on an ssl should be https. Otherwise there will be at least a warning. However, you seem to be saying the opposite - that insecure content shows up, but secure content doesn't. Is that right?

In any case, this may have nothing to do with secure vs insecure.

If you want more help:

Please post a link to a page on your site that contains the problematic code so we can check it out.

ddadmin
11-09-2010, 04:32 AM
Hmm this sounds like an inherent issue with scripts that are behind SSL- depending on how the user chooses to display the page (only secure portions or everything), you run the risk of the page not rendering properly. What happens if you change the reference to ddimgtooltip.js so it's no longer secure:


http://www.mixon.com/ssl/ddimgtooltip.js

? You should make the same changes for any images referenced by the .js file as well.

KevScott
11-09-2010, 01:14 PM
I changed all .js files to https what I was missing was the query.min.js file