PDA

View Full Version : Issue with Flex Level Drop Down Menu (v1.1) in IE



vmallamp22
11-01-2010, 04:31 PM
1) Script Title: Flex Level Drop Down Menu (v1.1)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/flexdropdown.htm

3) Describe problem: In IE 7.0 lower level menu is not rendered on first time mouseover, but when I mouseover second time, menu is rendered..

Attached are the screen shots of the same. This is not happening in other browsers..

Thank you.
Vasu.

jscheuer1
11-02-2010, 03:25 AM
In web design a picture almost never paints a thousand words. We probably need to see the live page, to see its code.

If I had to guess though, I'd guess that you either have no DOCTYPE or, if you do, one that doesn't put IE into standards mode.

Try putting this:


<!DOCTYPE html>

as the very first thing in the page's source code, before anything/everything else. Before even a space or the opening <html> tag.

If you want more help:

Please post a link to a page on your site that contains the problematic code so we can check it out.

vmallamp22
11-10-2010, 06:53 PM
Hi,

Link is not available externally. But zipped the html with and am uploading the source code..

Open html file in IE, mouse over the Products in top menu and then mouse over to "Viral transduction" first time it is blank when you move mouse to the submenu above then point mouse to "Viral transduction" it displays the sub sub menu..

Thank you for the help..

Vasu.

jscheuer1
11-11-2010, 04:28 AM
I'm surprised you didn't try what I guessed. That fixes it here. Replace:


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

With:


<!DOCTYPE html>


__________________


As a side note - nothing to do with this particular issue, notice that:




at the beginning of the old code? That's a Byte Order Mark or BOM. Older editors, even newer ones if the wrong option or setting is used, will place that at the beginning of a file that's saved as UTF-8. Saving as UTF-8 and using the (as the page already does):


<META http-equiv=Content-Type content="text/html; charset=utf-8">

meta tag is generally just good practice.

But that BOM can really mess things up sometimes. It should never be used.
.

vmallamp22
11-12-2010, 06:57 AM
Hi John,

Now it is working.. The problem is if I have couple of comment lines befire DOCTYPE as below it is not working..

<!-- $Header: xxclt_ibeCCtdCmnSctLayout.jsp 120.2 2006/01/17 21:50:23 ssekar ship $ -->
<!-- $Header: ibeCZzpHeader.jsp 120.23.12000000.4 2008/07/17 12:09:26 ukalaiah ship $ -->


Is there any workaround..

Thank you.
Vasu.
<!DOCTYPE html>

vmallamp22
11-12-2010, 07:00 AM
Hi John,

If I have <!DOCTYPE HTML> as the first line it is working..

But I had it as follows..

<!-- $Header: xxclt_ibeCCtdCmnSctLayout.jsp 120.2 2006/01/17 21:50:23 ssekar ship $ -->
<!-- $Header: ibeCZzpHeader.jsp 120.23.12000000.4 2008/07/17 12:09:26 ukalaiah ship $ -->
<!DOCTYPE HTML>

it is not working..

Do you have a workaround for this.

Thank you for all the help..

Vasu.

jscheuer1
11-12-2010, 07:21 AM
Sorry, no comments allowed in IE before the DOCTYPE. You could put server side code there, like PHP or asp, etc., if it actually gets used by the server. But a comment throws IE back into quirks mode. That's what caused the problem in the first place.

vmallamp22
11-12-2010, 04:07 PM
Thank you John.

Vasu.