PDA

View Full Version : Nothing shows up for Simple Controls Gallery



_drc
10-26-2010, 05:34 PM
1) Script Title: Simple Controls Gallery v1.3

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/simplegallery.htm

3) Describe problem: I copied everything as per the instructions and everything is in the same folder but nothing shows up when I preview it in a browser. The page is in the same folder with the .js scripts and the control images and the source images but nothings shows up when previewed?





<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>

<script type="text/javascript" src="jquery-1.2.6.pack.js"></script>

<style type="text/css">

/*Make sure your page contains a valid doctype at the top*/
#simplegallery1{ //CSS for Simple Gallery Example 1
position: relative; /*keep this intact*/
visibility: hidden; /*keep this intact*/
border: 10px solid darkred;
}

#simplegallery1 .gallerydesctext{ //CSS for description DIV of Example 1 (if defined)
text-align: left;
padding: 2px 5px;
}

</style>

<script type="text/javascript" src="simplegallery.js">

/***********************************************
* Simple Controls Gallery- (c) Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for this script and 100s more
***********************************************/

</script>

<script type="text/javascript">

var mygallery=new simpleGallery({
wrapperid: "simplegallery1", //ID of main gallery container,
dimensions: [250, 180], //width/height of gallery in pixels. Should reflect dimensions of the images exactly
imagearray: [
["1269.jpg", "http://en.wikipedia.org/wiki/Swimming_pool", "_new", "There's nothing like a nice swim in the Summer."],
],
autoplay: [true, 2500, 2], //[auto_play_boolean, delay_btw_slide_millisec, cycles_before_stopping_int]
persist: false, //remember last viewed slide and recall within same session?
fadeduration: 500, //transition duration (milliseconds)
oninit:function(){ //event that fires when gallery has initialized/ ready to run
//Keyword "this": references current gallery instance (ie: try this.navigate("play/pause"))
},
onslide:function(curslide, i){ //event that fires after each slide is shown
//Keyword "this": references current gallery instance
//curslide: returns DOM reference to current slide's DIV (ie: try alert(curslide.innerHTML)
//i: integer reflecting current image within collection being shown (0=1st image, 1=2nd etc)
}
})

</script>
</head>

<body>

<div id="simplegallery1"></div>

</body>
</html>

jscheuer1
10-27-2010, 07:35 AM
You may need more than one image array. The one image you do have (1269.jpg) may be a 404 not found. In IE there can be no comma after the last image array:



. . . rg/wiki/Swimming_pool", "_new", "There's nothing like a nice swim in the Summer."],

If you want more help:

Please post a link to a page on your site that contains the problematic code so we can check it out.

_drc
11-01-2010, 05:26 PM
There is no link to the page because Im not putting it online if it doesn't work. I copied and pasted the code and it just doesn't work. I don't know what else to do.

jscheuer1
11-01-2010, 06:15 PM
I need a link to a page that shows the problem happening (it can just be an orphan page somewhere on your site/the net, doesn't have to be linked to or from your other pages). Otherwise it would be just a shot in the dark and/or a game of twenty questions trying to solve this issue/issues for you. It does need to have all of its resources (images, external scripts snd styles, etc.).

If it's just a question of getting it to work though, follow the step by step instructions on the demo page. Do not deviate from them in any way. Once you have that working, then you may start customizing it. Keep backups along the way so that you can see the part where (if any) you're going wrong.