PDA

View Full Version : Fade-in & tigra_scroll [ie-OK, fireFox-NotOK] :(



zecozer
11-01-2005, 08:59 PM
Your fade-in slide-show is really great. However I wanted to use it on my webpage where I am also using tigra-scroll (http://www.softcomplex.com/products/tigra_scroller/) to scroll news items on the page.

For some reason, in FireFox and Netscape when I use your fade-in script my tigra-scroll items flicker and showup while fade transition is happening.

Any suggestion as to what may be the tweak either in fade-in or tigra-scroll so they both work ok?

jscheuer1
11-01-2005, 10:46 PM
Due to the complexity of the Tigra scroller, the solution I recommend trying first would be to put the fade-in slideshow on a separate page and have that page show through onto your page that uses Tigra via an iframe. If that doesn't solve the problem, it likely is a bug in the browser(s) that are exhibiting the odd behavior rather than any problem of the scripts conflicting. If this does solve the problem and you are looking for a way to avoid the iframe, a search through the two scripts would be required to find any variable, function, class and/or id names that are shared between them that may be causing trouble as well as any conflicting onload functions that may exist. I would recommend just being happy if the iframe solution works and, if need be, getting back to us here if you need help getting it (the iframe) to look as though it is actually on the page rather than showing through it, a relatively simple task. This is because, even if the scripts pass the iframe test, they still may not be able to be shown on the same page without it, due to browser peculiarities.