View Full Version : Dynamic Ajax Content Problem

09-25-2010, 12:35 PM
1) Dynamic Ajax Content

2) http://www.dynamicdrive.com/dynamicindex17/ajaxcontent.htm

3) Hello, Just like to start by saying this is an excellent site and it has helped me immensely, thank you very much for making these codes available :)

I am currently building a site and am using the dynamic ajax content code, here is a link to the page I am currently using it on http://www.hm-designs.co.uk/crossland/solo.php if you click on the solo name 1 link at the top of the left hand column you will see that the page loads fine, BUT if you click back or click away from the page then go back to try and view the solo name 1 page again, the tab section at the bottom containing the media bits and bobs doesnt work? Is this because it isnt applying the tabs.js file? or is there another reason why this is happening? I wish I knew more about javascript so I could troubleshoot this myself but I havent a clue where to start and I am still learning :confused:

Thank you in advance for any help you can give me :)


09-25-2010, 01:06 PM
**EDIT: I answered my own question :-)

Still having the issues I mentioned in first post though :-(

09-28-2010, 12:14 PM
I have just realised at the bottom of the Dynamic Ajax Content page it says:

Also, this function will remember when a CSS or JS file has already been loaded and applied to the page, and won't load the same file again even if the link that invokes it is clicked on multiple times. This is for sake of efficiency.

Could this be the reason that the tabs are breaking? because the tabs.js file isnt being applied everytime?


10-01-2010, 10:45 AM
Can anyone help me with this?

I have tried and tried to solve it myself but I cant, I dont know enough about javascript. I am willing to pay someone to get this working for me, if anyone can shed some light that would brilliant

The issue is that the tabs.js file that I am loading through the ajax dynamic content is not working after the page has been visited once. The css files are working though.

Thanks again,