PDA

View Full Version : Dynamic Ajax Content Not Working in Chrome



akDesign
09-02-2010, 04:04 PM
1) Script Title: Dynamic Ajax Content

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex17/ajaxcontent.htm

3) Describe problem:

I have this script currently mounted at:

http://www.willingsuspensionproductions.com/players.html

It seems to be working correctly in all browsers except for Chrome, I was hoping there might be a known fix for this.

Thank you

jscheuer1
09-02-2010, 05:35 PM
Works in Chrome here.

One thing to note about AJAX. Browsers defend against it being deployed cross domain as this could result in some clever phishing and/or other fraudulent activities.

The same is true of certain iframe and frame deployments.

It's a known (I don't know how widely known) fact that Google Chrome is one of the more aggressive in this area. It's not necessarily more efficient, just more aggressive.

As a result, when testing any of these implementations locally, Google Chrome may appear not to work. I believe this to be primarily because it erroneously considers any page not in the current local folder to be on another domain. It could be something else, or this and one or more other things.

I see that your external pages are in another folder, so this will probably not work locally in Chrome. However, as I say, the live page works just fine here in Chrome.

If your live page doesn't work in your Chrome browser, perhaps its settings are preventing it from doing so.


As a side note - IE and other browsers have similar issues at times insofar as not working locally, yet working live with certain implementations. The mechanisms are sometimes similar, at others times due to other browser quirks.

The bottom line though is to never assume something doesn't work in a particular browser until tested live.