PDA

View Full Version : Resolved PHP Photo Album script v2.11 not working



hr1
08-14-2010, 09:45 PM
1) Script Title: PHP Photo Album script v2.11

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/php-photoalbum.htm

3) Describe problem:
I tried the script on my website, but it's just not displaying anything.
To try finding out the error, I created a new folder "/test" and uploaded everything in this folder, the getalbumpics.php, ddphpalbum.js
and ddphpalbum.css.
I also uploaded three JPGs and one PNG in that same folder.
Then I created a test.html in the same "/test"-folder with the following code:


<html>

<head>
<script type="text/javascript" src="getalbumpics.php?id=myvacation"></script>

<script type="text/javascript">

//Optional, manual description for particular pictures inside album
//Syntax: albumid.desc[index]="Picture description here"
//eg: myvacation.desc[2]="This is description for the 3rd picture in the album"
//eg: myvacation.desc[6]="This is description for the 7th picture in the album"

</script>

<script type="text/javascript" src="ddphpalbum.js">

/***********************************************
* PHP Photo Album script v2.0- (c) Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for this script and 100s more
***********************************************/

</script>

<link rel="stylesheet" type="text/css" href="ddphpalbum.css" />
</head>

<body>

<script type="text/javascript">

new phpimagealbum({
albumvar: myvacation, //ID of photo album to display (based on getpics.php?id=xxx)
dimensions: [3,2],
sortby: ["file", "asc"], //["file" or "date", "asc" or "desc"]
autodesc: "Photo %i", //Auto add a description beneath each picture? (use keyword %i for image position, %d for image date)
showsourceorder: true, //Show source order of each picture? (helpful during set up stage)
onphotoclick:function(thumbref, thumbindex, thumbfilename){
thumbnailviewer.loadimage(thumbref.src, "fit2screen")
}
})

</script>

</body>
</html>

When I call the /test/test.html in my browser (FF 3.6.8) I can only see a white page.

Of course PHP and JS are activated on my server.

Please help me!

hr1
08-14-2010, 09:54 PM
Resolved:
I had been in a .htaccess protected developer area.
It's working on a different domain!