PDA

View Full Version : Resolved Ultimate Fade-in slideshow and z-indexes question!



Madragal
07-23-2010, 11:40 PM
1) Script Title: Ultimate Fade-in slideshow (v2.4)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem: I am currently having a problem with two different things. The most important problem that I am having is the slideshow's z-index. My current slideshow is located at the top of my page, just below my navigation. The navigation itself has pulldown menus, and when I hover over the pulldowns, its box goes beneath my slideshow container. To view what I mean, you can see it at http://melissakear.com/santafecasas/index2. I checked it on both my Mac and a PC, plus checked it in IE7, IE8, Firefox, and Chrome. I tried putting z-indexes of 1 in different areas of my CSS, but I am wondering if I am doing it wrong, because it does not seem to have made a difference. The actual navigational bar's container is at a z-index of 1, which fixed another problem I had with a slideshow on another page (which is a whole other story!), but I can't seem to figure this one out ...

Okay ... I'll put that out there before I go into another series of confusing questions lol. Thanks!

azoomer
07-23-2010, 11:48 PM
try this

#fadeshow1 {
margin: 10px auto;
z-index: 0;
}

Madragal
07-24-2010, 12:04 AM
Wow. It seems so simple, that I am embarrassed I didn't do that. Sigh! Thank you so much!!

jasonabc
08-12-2010, 04:35 AM
hi - I am also experiencing the exact same issue here - but the fix mentioned above doesn't work for me:

http://www.sweetpaperlane.com/

The top nav rollover DIVs all appear *behind* the slideshow. I've set z-indexes on the nav and menu divs to a really high number and set the slideshow to 1 but nothing works.

Any ideas?

thanks!

Jason

jasonabc
08-12-2010, 04:41 AM
footnote - got this solved - I found the answer in this post:

http://www.dynamicdrive.com/forums/showpost.php?p=210786&postcount=2

The trick was to add position:relative; to the fadeshow1 class as well as setting the z-index to 0.

hope this helps someone else.

cheers

Jason