PDA

View Full Version : Lightbox image viewer 2.03a: images appearing behind youtube video's



malhyp
07-05-2010, 03:03 AM
1) Script Title: Lightbox image viewer 2.03a

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem: images appearing behind youtube video's.

Hi there, we have installed Lightbox image viewer 2.03a andf noticed that when using latest version of IE that the images appear behind our youtube videos.

So when I click on an image, it opens up but if there are any youtube videos on the image, they are overlapping the image...

Can anyone help with this?

Cheers
M

azoomer
07-05-2010, 06:29 AM
In many cases it is the wmode bug causing this. Make sure you have the red paragraphs in the code for the embedded object.

<object width="600" height="385">
<param name="movie" value="http://www.youtube.com/v/YvWywBxmDEg&hl=en_US&fs=1&"></param>
<param name="allowFullScreen" value="true"></param>
<param name="allowscriptaccess" value="always"></param>
<param name="wmode" value="transparent"></param>
<embed src="http://www.youtube.com/v/YvWywBxmDEg&hl=en_US&fs=1&" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" wmode="transparent" width="600" height="385">
</embed>
</object>
Oh and by the way, if you also need the page to validate you can embed the youtube videos like this:

<object type="application/x-shockwave-flash" data="http://www.youtube.com/v/mZvRmE2NPjE&hl=en_US&fs=1&" width="600" height="385"><param name="allowFullScreen" value="true" /><param name="allowscriptaccess" value="always" /><param name="movie" value="http://www.youtube.com/v/mZvRmE2NPjE&hl=en_US&fs=1&" /><param name="FlashVars" value="playerMode=embedded" /><param name="wmode" value="transparent" /></object>
If this does not solve the problem you might want to post a link to the page.

malhyp
07-05-2010, 10:30 PM
Thanks for your reply, I updated the youtube script and it seems to be doing the same. The link http://www.enzabenincasa.com.au/media/media-publications.html.

If clicking on any of the images, try the ones closest to the youtube posts and you will see what I was saying.

azoomer
07-05-2010, 11:49 PM
I have just tried it and it looks very nice in all the browsers I have (latest FF, IE, safari,chrome and opera) . The youtube video stays behind the lightbox. What browser are you using ? Did you refresh the browser cache ? I would say that it works fine now.

malhyp
07-06-2010, 12:41 AM
Thanks again for your reply, yes I just tested it and it still appears. I also just noticed that I have comparability mode on. When i turn it off, everything seems fine.

Im using latest version of IE8.