PDA

View Full Version : dynamicindex14/leftrightslide.htm



bbdesign
06-23-2010, 03:25 PM
1) Script Title: Conveyor Belt slideshow script

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/leftrightslide.htm

3) Describe problem: On my page http://www.bbdesign.com/chiyodaamerica/about-us.htm I have an image scrolling that I would like to be seamless when it repeats. It works most of the time, but in some browsers there is a white line (gap) where the image repeats. This is not consistent, however. I have seen it happen on at least Firefox and Safari. But even there, it might scroll through one time and be fine (no gap), but the next time scrolling through there is a gap! Very strange that it is such an inconsistent problem, even on the same page load! Anyway, just wondering if there is a solution. Thank you!

jscheuer1
06-24-2010, 01:01 AM
This is an old script. At that time (I'm only guessing, I'm not the author - though I have worked on the code for tweaks and use in other scripts many times), I don't think there was much concern with the type of precision your issue indicates.

In limited testing, it appears that the (from the configuration area of the script in the source code of your page):



//Specify pixels gap between each slideshow rotation (use integer):
var slideshowgap=0

is the 'problem'.

I say 'problem', because I guess it could be a feature, whatever. In any case, I set it to -2:


//Specify pixels gap between each slideshow rotation (use integer):
var slideshowgap=-2

and that seems to fix it.

You should also consider:

http://www.dynamicdrive.com/dynamicindex2/crawler/index.htm

I'm not certain if it will work out well with only one image. If not, you could repeat it one or more times. But, if set up properly, it will have no gap without having to resort to negative values.

bbdesign
06-24-2010, 12:35 PM
It seems that may have fixed the problems. Thanks very much!