PDA

View Full Version : Source code not working in IE explorer



gmorris24
06-15-2010, 06:56 PM
I have designed a webpage with the anylinkmenu.js found on this site and it works fine with Firefox but not with IE. I looked through the forum to find a problem similar to my own but had no success. here is a link to my site...

Link (http://www.pasadenarodeotexas.com/index_explorer.htm)

I am getting the errors:" 'divclass' is null or not an object " and "Expected identifier, string or number."

I am very new to web design and need all the help I can get.

Thanks,

Garrett

jscheuer1
06-16-2010, 12:41 PM
In your menucontents.js file you have:


var anylinkmenu2={divclass:'anylinkmenu', inlinestyle:'width:150px; background:#000000', linktarget:'_parent',} //Second menu variable. Same precaution.

Scroll the code block all the way to the right. See the highlighted red comma near the end? That's a technical syntax error. Most browsers will error correct for it. But IE 8 in quirks mode, and all earlier IE browsers regardless of mode will not error correct it. Get rid of that.

That's the:


"Expected identifier, string or number."

error and it actually comes first. The second one about the divclass is caused by the first. So correct that extra comma by getting rid of it and see what happens.

There could also be other problems. But that will at least get it working.

gmorris24
06-16-2010, 09:36 PM
It is amazing how the tiniest little thing can throw off an entire script...

Thank you so much for the help!