PDA

View Full Version : jquery Magnify doesn't work when uploaded to server



ndngirl
06-08-2010, 11:17 PM
1) Script Title: :: jQuery Image Magnify v1.1

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/imagemagnify.htm

3) Describe problem:

I created a website using Dreamweaver CS4 and jquery magnify and everything worked fine on my local workstation (Win7). I then uploaded the file to my server and the file started to have problems.

The text->graphic magnify no longer worked and instead would open the graphic in a new IE window. Sometimes the graphic itself would not magnify at all.

Today I upgraded to CS5 and now I can't get magnify to work..

Any ideas/suggestions?

djr33
06-08-2010, 11:56 PM
Please post a link to the page on your site that contains the problematic script so we can check it out.

ndngirl
06-09-2010, 01:30 PM
After some more testing... I am finding that it works on my desktop machine, but fails after uploading to the server. The page itself is located within our company intranet's cms website. I believe that is where I will find what needs to be corrected in order for this to work.

djr33
06-09-2010, 06:50 PM
Yes, that may be the problem. Check that all of the elements are kept in the correct places: the javascript from the <head> section is still there, the <body> code is still there, and any other pieces aren't in some unexpected location. That may be the problem. Also, make sure the CMS is allowing the code: it might have converted part of it to plain text (for security reasons) so it's just displaying it rather than using it as code.
Finally if none of this works, it may be a conflict with an existing script (perhaps an overlapping variable name), or it might just not be installed correctly. Good luck.