PDA

View Full Version : OpenWYSIWYG issues



rppk
05-03-2010, 10:11 PM
1) Script Title: OpenWYSIWYG

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex16/openwysiwyg/

3) Describe problem: After editing a text with OpenWYSIWYG, the text file has added false style tags.

Example: <span style=\"\" bold;\\\\\\\\\\\\\\\\=\"\\&quot;\\\\&quot;\\\\\\\\&quot;\\\\\\\\&quot;\\\\&quot;\\&quot;\">

Other text formatting, such as bolded text, has been undone.

The editor works fine on my local php development machine but not on the web server.

I would be glad for help!

traq
05-04-2010, 01:02 AM
this is likely a server issue, not something wrong with the script. try get_magic_quotes_gpc(); if it returns 1, then magic quotes are on you need to disable them (via php.ini is best, read more here (http://us.php.net/manual/en/info.configuration.php#ini.magic-quotes-gpc)).

djr33
05-04-2010, 01:42 AM
Yes, I agree. All I have to add is that magic quotes are very annoying because they can be enabled (and disabled) at several levels: php.ini; .htaccess; and at least 2 ways within the script itself. While investigating this and trying to fix it, don't give up because this is probably the issue even if you can't find a way to disable it for a while. It could be coming from a few places and "fixing" one of them might make it seem like nothing was fixed, but don't worry-- this is very likely the right direction.
Do whatever you can to disable them and then everything will be fixed.
(They're a remnant of a while ago when the thought was that it made sense to "guess" that everything you submit needs the slashes added to securely add it to a database, but in reality more often than not this just confuses things. The good news is that it's fading out and rarely used at this point. New server configurations rarely have it, and the newest versions of PHP don't include it at all. So... just a matter of time.)

traq
05-04-2010, 04:05 AM
a LOT of servers still have it -and ON by default, too. I am constantly amazed by the number of servers (including 1&1, hostmonster, and even mediatemple) that have php 4 enabled by default.

djr33
05-04-2010, 04:22 AM
A constant annoyance indeed.

rppk
05-04-2010, 11:01 AM
Thanks for the helpful and detailed replies!

I will try to turn magic quotes off today and will let you know if I got openWYSIWYG to work on the server. Thanks!

rppk
05-04-2010, 11:56 AM
Turning magic quotes off in php.ini or .htaccess wasn't enough, but Bluehost tech support was able to turn it off on their end.

OpenWYSIWYG now works as it should! Thanks a lot for your help!

traq
05-04-2010, 03:21 PM
good :)