PDA

View Full Version : Fade-in slideshow working locally not online



Stueadie
04-20-2010, 08:47 AM
1) Script Title: Ultimate Fade-in slideshow (v2.1)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem: Everything works fine when I preview on my computer locally. I have uploaded the files to the remote server and it doesn't work.
I am a novice at this. I was very excited to see it work relatively easily. Can someone please help?

http://www.redlampfilms.com/mongrel.html

ddadmin
04-20-2010, 09:05 PM
It looks like the paths to the images inside the slideshow are incorrect:


var mygallery=new fadeSlideShow({
wrapperid: "fadeshow1", //ID of blank DIV on page to house Slideshow
dimensions: [1000, 300], //width/height of gallery in pixels. Should reflect dimensions of largest image
imagearray: [
["Fadeshow/pic1.jpg", "", "", "Two crazy kids"],
["Fadeshow/pic2.jpg", "mongrel.html", "_new", "The Same Two Crazy Kids"],
["Fadeshow/pic3.jpg"],
["Fadeshow/pic1.jpg", "", "", "What a beautiful scene with everything changing colors."] //<--no trailing comma after very last image element!
],
displaymode: {type:'auto', pause:2500, cycles:0, wraparound:false},
persist: false, //remember last viewed slide and recall within same session?
fadeduration: 500, //transition duration (milliseconds)
descreveal: "ondemand",
togglerid: ""
})

For example, if you look at the path in red hightlighted above, it points to a non existent image: http://www.redlampfilms.com/Fadeshow/pic1.jpg. If in doubt change all of the references above to absolute URLs.

Stueadie
04-20-2010, 11:21 PM
Thanks. I tried to remove the post before anyone saw it. I came in this morning and saw the problem straight away. (what a goose) Many Thanks.