PDA

View Full Version : Images not showing on web page



beartrax
03-27-2010, 02:49 PM
1) Script Title: Blending Image Slide Show Script

2) Script URL (on DD):http://www.dynamicdrive.com/dynamicindex14/image4.htm

3) Describe problem: Images not showing on page.

Hello everyone.
This is my first attempt using this script on a website I'm building. I decided to use this over a flash script for many reasons.
I followed the instructions in the script very carefully, placing the portion indecated in the <HEAD> of the page as well as the portion indecated for the <BODY>. Changed the img src in the body to the first image in the slideshow and changed the var slideshow in the head to reflect the images I want in the slideshow.

When I load the web page, I get a placeholder where the images should be, but no images.
I'm not sure at this point what the issue is. When I right click where the image should be and go to properties, I see the name of the image as the script calls for but no image.

Can anyone shead some light on this problem?
I am posting both the <HEAD> & <BODY> portions as there might be some coding problem.
Thank you for any and all input.

<head>

<script language="JavaScript1.1">
<!--

//*****************************************
// Blending Image Slide Show Script-
// Dynamic Drive (www.dynamicdrive.com)
// For full source code, visit http://www.dynamicdrive.com/
//*****************************************

//specify interval between slide (in mili seconds)
var slidespeed=3000

//specify images
var slideimages=new Array("aliceinchains-artwork.jpg","anberlin.jpg", "breakingbenjamindearagony300.jpg", "chevellescificrimes.jpg", "Crash.jpg", "AFI.jpg", "Flyleaf.jpg", "Silver.jpg", "wolfgang-amadeus-phoenix-album-cover.jpg", "30-Seconds-To-Mars-This-Is-War")

//specify corresponding links
var slidelinks=new Array()

var newwindow=1 //open links in new window? 1=yes, 0=no

var imageholder=new Array()
var ie=document.all
for (i=0;i<slideimages.length;i++){
imageholder[i]=new Image()
imageholder[i].src=slideimages[i]
}

function gotoshow(){
if (newwindow)
window.open(slidelinks[whichlink])
else
window.location=slidelinks[whichlink]
}

//-->
</script>

</head>

<BODY>
<h2 class="decay-small">Current TOP 10</h2>

<table border="0" cellpadding="0" cellspacing="0">

<tr>

<a href="javascript:gotoshow()"><img src="aliceinchains-artwork.jpg" name="slide" border=0 style="filter:blendTrans(duration=3)" width=200 height=200></a>

<script language="JavaScript1.1">
<!--

var whichlink=0
var whichimage=0
var blenddelay=(ie)? document.images.slide.filters[0].duration*1000 : 0
function slideit(){
if (!document.images) return
if (ie) document.images.slide.filters[0].apply()
document.images.slide.src=imageholder[whichimage].src
if (ie) document.images.slide.filters[0].play()
whichlink=whichimage
whichimage=(whichimage<slideimages.length-1)? whichimage+1 : 0
setTimeout("slideit()",slidespeed+blenddelay)
}
slideit()

//-->
</script>


</tr>

</table>
</body>

beartrax
03-28-2010, 11:40 PM
Help plz.
I posted this yesterday and have had 75 views and not a response. I chose this site on a friends reccomendation for it's outstanding support. Can someone take the time and help with this issue?

Thank you.

jscheuer1
03-29-2010, 04:55 AM
It can be hard, and often fruitless to wade through posted code. It is much easier, and often much more beneficial to diagnose a live page:

Please post a link to a page on your site that contains the problematic code so we can check it out.