PDA

View Full Version : Ultimate Fade-in Slideshow not working on Symbian browser



lukebrenner
03-19-2010, 07:24 PM
1) Script Title: Ultimate Fade-in Slideshow 2.1

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem: The script simply doesn't work on Nokia Symbians. Anyone knows why ? Works perfectly on all browsers on the computer but on the original Symbian browser the images do not fade or switch at all.

Thanks

jscheuer1
03-20-2010, 05:31 AM
Are you using the Symbian emulator, or an actual Nokia phone with Symbian? (from what I hear the emulator lags behind the actual Symbian browser in use on Nokia, and that the emulator cannot view live pages)

In any case, Symbian is based upon webkit (Safari, Chrome, others), so in theory should work. Perhaps something is disabled in your Symbian browser that prevents it from working. Do other javascripts work in your Symbian?

Unless you are getting a specific error message though, there is not a lot I (or probably anyone) can do about it. The slide show uses the jQuery javascript library, so it is possible that there is an incompatibility.

Try:

http://home.comcast.net/~jscheuer1/side/files/u_fade_151_try_catch.htm

If that works, it's probably due to a lack of support in jQuery for Symbian. But you can double check that theory by trying:

http://home.comcast.net/~jscheuer1/side/vfs/test_7.htm

If that works, it may be the version of jQuery, or something else in the Ufade 2.1 code.

Another script you might try is:

http://www.dynamicdrive.com/dynamicindex14/swissarmy/index.htm

If that works in Symbian, it can probably be adapted to do what you need.