PDA

View Full Version : ddsmoothmenu problem in IE8



gr00vytunes
03-12-2010, 01:31 PM
1) Script Title: ddsmoothmenu

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm

3) Describe problem: The Menu works perfect in Firefox at www.fvpa.co.uk but in IE8 it does not render correctly, I have had it working, but am at a loss as to why it is currently broken! I'm sure it must be related to the html menu links/names, i will keep trying to resolve it, in the meantime if someone has a few minutes to take a look that would be great..

Many Thanks

layout

[CODE]<!-- PULL DOWN MENU - BEGIN -->
<div id="smoothmenu1" class="ddsmoothmenu">
<ul>
<li><a href="#">HOME</a>
</li>
<li><a href="/phpbb3" target="_blank" >FORUM</a>
</li>
<li><a href="?id=48">NEWS</a></li>
<li><a href="http://www.youtube.com/FVPATV" target= "_blank">FVPA TV</a>
<ul>
<li><a href="?id=86">COMMUNITY SHIELD 21st Feb 2010</a></li>
</ul>
</li>

<li><a href="#">LEAGUES</a>
<ul>
<li><a href="?id=60">PS3 - 10v10</a></li>
<li><a href="#">XBOX - 10v10</a>
<ul>
<li><a href="#">SUNDAY LEAGUE</a>
<ul>
<li><a href="?id=59">TABLE</a></li>
<li><a href="?id=59">RESULTS</a></li>
<li><a href="?id=59">FIXTURES</a></li>
<li><a href="/phpbb3/viewforum.php?f=65" target="_blank">SUBMIT RESULT</a></li>
<li><a href="/phpbb3/viewtopic.php?f=57&t=130">DISPUTE RESULT</a></li>
</ul>
</li>
</li><a href="#">Reserved</a></li>
</ul>
</li>
</ul>
</li>
<li><a href="#">TOURNAMENTS</a>
<ul>
<li><a href="?id=88">PS3 - 10v10</a></li>
<li><a href="#">XBOX - 10v10</a>
<ul>
<li><a href="?id=51">COMMUNITY SHIELD</a></li>
<li><a href="?id=87">FVPA SUPER SUNDAY</a></li>
</ul>
</li>
</ul>
</li>
<li><a href="#">USEFUL LINKS</a>
<ul>
<li><a href="http://live.xbox.com/en-US/default.aspx" target="_blank">XBOX LIVE</a></li>
<li><a href="http://www.playstation.com" target="_blank"">PLAYSTATION</a></li>
<li><a href="http://www.easports.com/"target="_blank">EA SPORTS</a>
<ul>
<li><a href="http://forums.electronicarts.co.uk/fifa-10-clubs/" target="_blank">EA CLUBS FORUM</a></li>
<li><a href="http://www.easportsfootball.co.uk/" target="_blank">EA SPORTS FOOTBALL</a></li>
<li><a href="http://www.eafootballworld.com/en_GB/clubs" target="_blank">EA PRO CLUBS</a></li>
</ul>
</li>
<li><a href="#">VP RESOURCES</a>
<ul>
<li><a href="http://www.easports.com/enGB/blogs/fifa/offthebench/post/slug/fifa-10s-virtual-pro-welcome-to-the-start-of-your-virtual-football-career" target="_blank">INFORMATION</a></li>
<li><a href="http://www.eagames.co.uk/news/fifa-10-game-face-how-to" target="_blank">GAMERFACE</a></li>
<li><a href="http://forums.electronicarts.co.uk/fifa-10-sony-playstation-3-microsoft-xbox-360/828314-virtual-pro-accomplishments.html" target="_blank">ACCOMPLISHMENTS</a></li>
</ul>
</li>
</ul>
</li>
<li><a href="?id=49">CONTACT US</a>
<ul>
<li><a href="?id=49"><span>MEET THE TEAM</span></a></li>
<li><a href="/phpbb3/chat" target="popup" onClick="wopen('/phpbb3/chat', 'popup', 800, 600); return false;"><span>LIVE CHAT</span></a></li>
</il>
</ul>[ICODE]

gr00vytunes
03-12-2010, 02:34 PM
ok found out I had some </il> and </ul> in the wrong places..

To work it out I deleted code backwards until the bar looked correct, then i added each menu item in turn.. Voila !