PDA

View Full Version : Logo Hassle



irishcavan
10-02-2005, 04:19 AM
i need some help. I have some basic instructions on changing the logo from the default to my own. However, it is not updating and changing. Below are the instructions that i followed, and the header.php code that i changed

Logo: irishimports.gif
Directions:
1. Using an FTP client (eg. Filezilla) download the ../catalog/includes/header.php file
2. Using a text editor (eg. Notepad) edit the header.php file as follows:

In the existing code:
<?php echo tep_image(DIR_WS_IMAGES . 'oscommerce.gif', 'OSCommerce'); ?>

(a)Replace 'oscommerce.gif' with yourlogo.gif (where yourlogo.gif is the name of your image file (for your company logo))
(b)Replace 'OSCommerce' with the name of your company
(c)Using your FTP client upload the revised header.php file back to the server to ../catalog/includes/

2. Using an FTP client upload yourlogo.gif (the filename for your company's logo) to the images folder ../catalog/images/



<?php
/*
$Id: header.php,v 1.19 2002/04/13 16:11:52 hpdl Exp $

osCommerce, Open Source E-Commerce Solutions
http://www.oscommerce.com

Copyright (c) 2002 osCommerce

Released under the GNU General Public License
*/

if ($messageStack->size > 0) {
echo $messageStack->output();
}
?>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
<tr>
<td><?php echo tep_image(DIR_WS_IMAGES . 'irishimports.gif', 'Irish Imports', '185', '117'); ?></td>
<td align="right"><?php echo '<a href="http://www.anirishtouch.com" target="_blank">' . tep_image(DIR_WS_IMAGES . 'header_support.gif', HEADER_TITLE_SUPPORT_SITE, '50', '50') . '</a>&nbsp;&nbsp;<a href="' . tep_catalog_href_link() . '">' . tep_image(DIR_WS_IMAGES . 'header_checkout.gif', HEADER_TITLE_ONLINE_CATALOG, '53', '50') . '</a>&nbsp;&nbsp;<a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_administration.gif', HEADER_TITLE_ADMINISTRATION, '50', '50') . '</a>'; ?>&nbsp;&nbsp;</td>
</tr>
<tr class="headerBar">
<td class="headerBarContent">&nbsp;&nbsp;<?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_TOP . '</a>'; ?></td>
<td class="headerBarContent" align="right"><?php echo '<a href="http://www.anirishtouch.com" class="headerLink">' . HEADER_TITLE_SUPPORT_SITE . '</a> &nbsp;|&nbsp; <a href="' . tep_catalog_href_link() . '" class="headerLink">' . HEADER_TITLE_ONLINE_CATALOG . '</a> &nbsp;|&nbsp; <a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '" class="headerLink">' . HEADER_TITLE_ADMINISTRATION . '</a>'; ?>&nbsp;&nbsp;</td>
</tr>
</table>


It has been suggested by others to just rename my logo oscommerce.gif however, this is NOT what i want to do. If I am going to change code, I would like to do it properly. Any help would be GREATLY appreciated, as I am just now learning PHP.

Thanks,

Irish :confused: :eek:

mwinter
10-02-2005, 08:58 PM
i need some help. I have some basic instructions on changing the logo from the default to my own. However, it is not updating and changing.Without downloading the product, finding the relevant code, reading it, understanding it, then working out why you're having problems, it's unlikely that anyone here will be able to help you.

As far as I can see, OSCommerce has it's own support forums (http://forums.oscommerce.com/). You are more likely to find someone with experience with the system there.

I'm sorry that I couldn't offer more help than that.

Good luck,
Mike