PDA

View Full Version : Lightbox image viewer 2.03a - Not working on server



Christo70
02-22-2010, 02:08 AM
Script Title: Lightbox image viewer 2.03a

http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

I have the script working on my local computer but when I upload the site to a remote server the script breaks. When an image is clicked the full size photo loads in a new blank page.

I have the Lightbox files arranged in my site root like this:

Site Root/
Lightbox2.03a/
js/
images/
css/

Being that it works on my local drive I don't know what to change to make it work on a server. See link for site:

http://www.midcoast.com.au/~christo2/byf_site/gallery.html

Christo

bluewalrus
02-22-2010, 02:39 AM
The files that power it on your server have the wrong permissions.

Christo70
02-22-2010, 03:08 AM
Thanks for the fast reply. What do I do to change the permissions? I'm a newbie to all this stuff.

bluewalrus
02-22-2010, 04:09 AM
These files need to be accessible


<script type="text/javascript" src="lightbox2.03a/js/prototype.js"></script>
<script type="text/javascript" src="lightbox2.03a/js/scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="lightbox2.03a/js/lightbox.js"></script>
<link rel="stylesheet" href="lightbox2.03a/css/lightbox.css" type="text/css" media="screen" />


In an ftp program right click (control+click) the files or the directory and make them accessible to all. You can make them 777 or 755.

Christo70
02-22-2010, 10:21 AM
Hi,

Tried that. Permissions for those file are already et to 755.

I don't understand why it works locally but not on a remote server.

Christo70
02-22-2010, 01:13 PM
Ahh, after hours of looking for other solutions I realised permissions need to be applied to the lightbox folder as well!

It works, thanks!