PDA

View Full Version : crawler script errors



TroubleLovesMe007
02-17-2010, 12:37 PM
1) Script Title: crawler

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex2/crawler/index.htm

3) Describe problem: I added the script exactly as it is shown without modifying anything except my paths. This is the first time I have ever used Javascript, so this could be something extremely dumb - if so, I apologize in advance. I have over 40 images in this crawler each of the same size of 200x100. When I upload the test page I get this error in Firefox:
A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

IE8 tells me it is an invalid argument.

I cut down on my number of images but still got the same error.
What am I doing wrong?
Thank you so much--really appreciate your time.
I've been looking for something like this script to display our logos for a long time. You have to modify your host file in order to see this page live, so I hope you can just work with this:


<div class="marquee" id="mycrawler"></div>

<script type="text/javascript">
marqueeInit({
uniqueid: 'mycrawler',
style: {
'padding': '5px',
'width': '450px',
'background': 'lightyellow',
'border': '1px solid #CC3300'
},
inc: 8, //speed - pixel increment for each iteration of this marquee's movement
mouse: 'cursor driven', //mouseover behavior ('pause' 'cursor driven' or false)
moveatleast: 4,
neutral: 150,
savedirection: true
});
</script>

<div class="marquee" id="mycrawler2">
<img src="customer/shodis/images/logos/111209logos/aa.jpg" /><img src="customer/shodis/images/logos/111209logos/ab.jpg" />
<img src="customer/shodis/images/logos/111209logos/can.jpg" alt="Canon" /><img src="customer/shodis/images/logos/111209logos/comp.jpg" /><img src="customer/shodis/images/logos/111209logos/dalite.jpg" width="200" height="100" /><img src="customer/shodis/images/logos/111209logos/echo.jpg" width="200" height="100" /><img src="customer/shodis/images/logos/111209logos/fec.jpg" width="200" height="100" /><img src="customer/shodis/images/logos/111209logos/idx.jpg" width="200" height="100" /><img src="customer/shodis/images/logos/111209logos/ikmul.jpg" width="200" height="100" /></div>

<script type="text/javascript">
marqueeInit({
uniqueid: 'mycrawler2',
style: {
'padding': '2px',
'width': '600px',
'height': '180px'
},
inc: 5, //speed - pixel increment for each iteration of this marquee's movement
mouse: 'cursor driven', //mouseover behavior ('pause' 'cursor driven' or false)
moveatleast: 2,
neutral: 150,
savedirection: true
});
</script>
</body>


THANKS AGAIN!:o

jscheuer1
02-18-2010, 06:15 AM
There could also be other problems, but this has to go (remove it):


<div class="marquee" id="mycrawler"></div>

<script type="text/javascript">
marqueeInit({
uniqueid: 'mycrawler',
style: {
'padding': '5px',
'width': '450px',
'background': 'lightyellow',
'border': '1px solid #CC3300'
},
inc: 8, //speed - pixel increment for each iteration of this marquee's movement
mouse: 'cursor driven', //mouseover behavior ('pause' 'cursor driven' or false)
moveatleast: 4,
neutral: 150,
savedirection: true
});
</script>

The reason being that it is trying to initialize an empty crawler.

If you want more help:

Please post a link to a page on your site that contains the problematic code so we can check it out.