PDA

View Full Version : jquery on Animated Collapsible DIV v2.4 needs update



FrickenTrevor
02-15-2010, 05:15 AM
1) Script Title:

Animated Collapsible DIV v2.4

2) Script URL (on DD):

http://www.dynamicdrive.com/dynamicindex17/animatedcollapse.htm

3) Describe problem:

Its not that big of a problem BUT I would like to point out that Google Apis now has v.1.4.1 of jquery out instead of 1.3.2

Here is the link:
http://ajax.googleapis.com/ajax/libs/jquery/1.4.1/jquery.min.js

jscheuer1
02-15-2010, 09:47 AM
I don't understand. Does the script require updating to work with jQuery's latest version? Or do you just think it should now use v1.4.1?

FrickenTrevor
02-16-2010, 04:02 AM
Erm, no. The script doesnt need updating to work with jQuery's latest version
I tested the script on the DD page with IE 6 and 7 and Fire Fox 3. Works fine.
I just thought since there is an update on jquery (http://jquery.com/), the update should be reflected on the DD page.
Sorry if I caused any trouble

jscheuer1
02-16-2010, 04:31 AM
No trouble. This was actually the first I've heard of jQuery 1.4.1. So I'm glad you posted. I just wasn't sure what you were saying about it visa vis the DD script, which incidentally I have little or nothing to do with, not having contributed to said script in any way other than helping a few folks with it.

FWIW, many DD scripts come with instructions to use jQuery 1.3.1, and many to use jQuery 1.2.6. It just depends upon when the DD script was written/last updated. However, most that use earlier versions of jQuery will also work with later versions of jQuery. It's really at the designer's discretion (in most cases) what version of jQuery they will use with a given jQuery based DD script. Those scripts that will not work with later versions of jQuery generally can be made to do so with minor changes. AFAIK, ddadmin is the only current author of DD scripts that employ jQuery. He's a busy guy, so updating the reference to 1.4.1 is probably not high on his list of priorities for any given DD script.

Still, it's nice to know a new version of jQuery is available and that this particular script works with it.