View Full Version : Stuck on "Ticker Initializing Message"

02-09-2010, 03:27 AM
1) Script Title: LastRSS bridge

2) Script URL (on DD): http://www.dynamicdrive.com

3) Describe problem: I have run this script without a problem for the last couple of months until recently when I had to change the URL of the .xml feed. Now when I run the script it just hangs at "Ticker Initializing".

When I run the bridge url: Click Here (http://signboard.stephenleacock.ca/Scripts/rsstickerajax/lastrss/bridge.php?id=leacocknews) it works fine and returns (what I think) is the correct feed.
But the ticker will not display it. What might be the trouble??


02-09-2010, 03:36 AM
What's the URL to the page on your site displaying the ticker?

02-09-2010, 09:25 PM
I have switched to the gAjax RSS Ticker (hosted) script and am grabbing feeds from a Google group Rss feed. How do I change the cache time so that it updates the Rss feed more frequently?

02-10-2010, 03:15 AM
Never mind.. I found this explanation:
"Bear in mind, however, that Google Feeds API caches the specified RSS feeds on their servers, and only refreshes them around once every hour. This means it's usually futile to be calling the init() function every few minutes, as the same content will most likely be returned.":confused:

02-10-2010, 04:20 AM
I was just going to comment that the ticker seems to be working for me. As far as the caching duration, yes, unfortunately you're at the mercy of Google Feed API when it comes to that. From the Google documentation:

Feed Crawl Frequency

As the Google AJAX Feed API uses Feedfetcher, feed data from the AJAX Feed API may not always be up to date. The Google feed crawler ("Feedfetcher") retrieves feeds from most sites less than once every hour. Some frequently updated sites may be refreshed more often.