PDA

View Full Version : HV Menu Q's (not for the weak of heart)



SCJVS1
09-28-2005, 11:14 PM
Um......hi again.

Sorry to bother anyone with this thread but... If any one can help, any advice on this thread will be very much appreciated.

With this page

web page buttons (http://www.scjvs.com/indexchange.html)


I was wondering if its possible to break 1 HV Menu up into two sections,
but if it isn't possible, thats ok. However, I have the page to where the buttons are separated/and aligned (just the way I want it). How do I keep the buttons from creating an <font color= "red">'Operation Aboted'</font> on Internet Exploer?



Here is the code I think might be causing the problems, or else the only thing keeping the buttons from showing is that the buttons are not compatible with the version of Internet Explorer that I have on my computer.



Here is some information, sorry so long, I tried to make it as simple as possible as a yes no question. Hopefully some one can read a mistake through here that will correct the problem.



I have the HV Menu on a web site "sample" page, I copied the buttons, really....they're not on the same page exactly. :confused:
Any way I had the first pair of buttons put in a iframe, which to get them to "pop" out of the iframe onto the page itself so the submenues can be seen, I changed the code in red:

examplmenu)var.js



<font color= "red">var StartTop=-415; // Menu offset x coordinate </font>
<font color= "red">var StartLeft=31; // Menu offset y coordinate </font>
var VerCorrect=0; // Multiple frames y correction
var HorCorrect=0; // Multiple frames x correction
var LeftPaddng=3; // Left padding
var TopPaddng=2; // Top padding
var FirstLineHorizontal=0; // SET TO 1 FOR HORIZONTAL MENU, 0 FOR VERTICAL
var MenuFramesVertical=1; // Frames in cols or rows 1 or 0
var DissapearDelay=1000; // delay before menu folds in
var TakeOverBgColor=1; // Menu frame takes over background color subitem frame
<font color= "red">var FirstLineFrame='self'; // Frame where first level appears </font>
<font color= "red">var SecLineFrame='self'; // Frame where sub levels appear </font>
<font color= "red"> var DocTargetFrame='self'; // Frame where target documents appear </font>
<font color= "red"> var TargetLoc='MenuPos'; // span id for relative positioning </font">


I changed these particular spots in the javascript code:

1. the first piece of code to chage arrangement of the buttons
2. the second group of code was used to get the buttons to "pop" out
of the iframe to give the sub buttons spare room to be seen.
3 * I used the TargetLoc id MenuPos twice on both buttons to have
an identifier, but (could that be a reason?) their not exactly on
the same page.







The next code is

examplmenu2_var.js

I used this code to have these group of buttons to show up on the actual web page:

var SecLineFrame='space'; // Frame where sub levels appear
var DocTargetFrame='space'; //Frame where target documents appear
var TargetLoc='MenuPos'; // span id for relative positioning


****Both groups of buttons are on the same page exept one came out onto the website from an Iframe and the other was directly added onto the website. The group of buttons on top are the ones that came out of an Iframe which I have hidden, which is of no concern right now. I just want the buttons to work. Well, they work just fine in Mozilla :p Its just IE, can't stand it anymore, its too stubborn. :D Thank You