PDA

View Full Version : Image Cover Problem using "Content Gilder"



telephonefield
01-12-2010, 03:30 PM
1) Script Title: Content Gider

2) Script URL (on DD):

http://www.dynamicdrive.com/dynamicindex17/featuredcontentglider.htm

3) Describe problem:

When using the gliding script to slide in 5 or 6 individual sections, some of the remaining content is not covered up entirely by the slide that is selected.

Demo: http://www.cidcom.at/demo/buder_herberstein/gliding-test/test.html

I have tried specifying a height for pretty much ALL DIVs that is high enough to cover it all, and specified a white background color, but that didn't really solve it at all.

I would post code, but I'm not sure what code would be most helpful in solving the problem.

I'm aware of some display problems in IE.

jscheuer1
01-12-2010, 04:19 PM
It's not the height, though that will come into play in some cases, so should be kept high, though perhaps not that high. It's the width, which should be the width of the wrapper, in this case 800px:



.glidecontent{ /*style for each glide content DIV within wrapper.*/
position: absolute; /* Do not change this value */
padding: 10px;
visibility: hidden;
width: 800px;
background-color: #ffffff;
height: 1500px;
}

This also looks promising, but may have problems in some browsers:


.glidecontent{ /*style for each glide content DIV within wrapper.*/
position: absolute; /* Do not change this value */
padding: 10px;
visibility: hidden;
width: 100%;
background-color: #ffffff;
height: 100%;
}