PDA

View Full Version : Smooth Menus and IE 8 Issue



gowindholz
01-03-2010, 04:20 AM
1) Script Title: Smooth Navigational Menu (v1.31)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm

3) Describe problem: Verticle Navigation not showing sub links unless moused over.

I am currently running this script here http://www.gowindholz.net/servlet/the-Bracelets/Categories but when I mouse over the Folder 2 tab it does not show the catergories that have sub categories unless I hover over them then it corrects itsself. I noticed the page where I down loaded the script works fine but it does not work out the same on my site. I figure it is something in the CSS file. Any suggestions?

It works fine on firefox and iphone apps just not with IE 8.

jscheuer1
01-03-2010, 05:07 AM
Works here on the DD demo page in IE 8. I see the problem in IE 8 on your page. Your page is being rendered in quirks mode. Chances are that if you used a DOCTYPE like:


<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

As the very first thing on the page followed immediately by the opening HTML tag (no comments), it would work in IE 8 for you too. But the page also has non-standard code, so that might also be a factor. However, if I force your page into IE 8 standards mode, that problem goes away, so the non-standard code probably isn't a factor in this.

gowindholz
01-03-2010, 05:15 AM
I add that line of code to the document and it worked perfectly. Thanks for all your help! I was at it for hours trying to make it work.

gowindholz
01-03-2010, 05:20 AM
I did notice after making the change everything on the page is centered. Any way for it to straighten its self back out?

jscheuer1
01-03-2010, 05:26 AM
It's hard to be certain, what with how quirky the code is, so there may be other factors. However, here (in your on page styles):


<STYLE type=text/css>
<!--
html {
overflow-y:scroll;
}
body {
margin:0px;
text-align:center;
background-color:#ffffff;
font-family:Arial, Helvetica, sans-serif;
}
a:link, a:visited {
text-decoration:none;
color:#000000;
} . .

If you get rid of that (highlighted), it will certainly fix things in some if not all browsers.

gowindholz
01-03-2010, 05:36 AM
I will try that, thanks again I am just stoked the menu is working. now comes the fun part of building the menu links.