PDA

View Full Version : Iframe loading?



Bluesplayer
12-11-2009, 09:34 PM
1) Script Title: Drill Down Menu (v1.6)

2) Script URL (on DD): http://dynamicdrive.com/dynamicindex1/drilldownmenu.htm

3) Describe problem: On using this menu with the code added directly into the page there is a delay with Explorer on showing the tabs or the whole menu looks messy until the page loads fully. The menu has been added to a shop script that takes some time to carry out it's search process. I was wondering if this menu could be loaded before the rest of the page. At the moment I have experimented with showing the menu within an iframe. Explorer now works perfectly with the menu stable at all times but there is a delay now with firefox. Nothing like as bad as with explorer when the code was added to the page though. If there is a way to load the content of an iframe first before the rest of the page I would also like to know about that too. You can see the menu being shown within an iframe here: http://bluesplayer-shops.hopto.org/sound_vision/. Really my query is can the menu be made to load before other page content that way I can put the code back into the page which I prefer.

Regards

ddadmin
12-12-2009, 07:22 AM
There's quite a few ways to go about this without having to resort to using an IFRAME actually. One way is just to hide the menu contents until it has initialized. Inside the .css file, simply add the line in red:


.drillmenu ul{ /*menu ULs*/
font: normal 13px Verdana;
margin: 0;
padding: 0;
list-style-type: none;
background: lightyellow; /*background of menu*/
visibility: hidden;
}

Bluesplayer
12-12-2009, 02:29 PM
Much better now - thanks.