PDA

View Full Version : Scripts problem



newbiegirl
12-03-2009, 10:50 PM
1) Script Title: Lightbox Image viewer v2.03a , Ultimate Fade-in slideshow (v2.1) , Blending Image Slideshow Script (Best seen with IE 4+)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/image4.htm x http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:
Hello, I have some problems with those scripts. I have all of them on my php page, and the ultimate fade in doesn't work when the lightbox script is on the page, but when I delete the lightbox script of my page, it works very well.

So what's the problem? We can't have several scripts on the same page? What can I do? I wanted to change the pics of the blending image slideshow, and it didn't worked anymore, so I wanted to try the ultimate one (that I prefer) and it doesn't work too just because of the lightbox script! But I need the lightbox... :confused: Please help me!

jscheuer1
12-04-2009, 07:44 AM
See this thread:

http://www.dynamicdrive.com/forums/showthread.php?p=211979#post211979

One thing not mentioned in there though is that the scripts for Ultimate fade should come before those for Lightbox.

newbiegirl
12-04-2009, 01:34 PM
Thank you for your help jscheuer1, it works perfectly now. I didn't know there was an update!
One question, the line : <link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen" /> has to be under the Ultimate fade script too?

jscheuer1
12-04-2009, 04:39 PM
No. In fact, though not critical, stylesheet links should generally come before script tags in the head of the document.

The only thing tricky about styles of any sort is that those that come later in the document (if there is any conflict/contradiction) will almost always overwrite any styles earlier in the document.

That's not an issue here as far as I know.