View Full Version : Animated Collapsible and Accordion Menu Conflict

11-10-2009, 03:42 PM
1) Script Title: Animated Collapsible DIV v2.4 / Accordion Menu script (v1.7.1)

2) Script URL (on DD):

3) Describe problem:
I am using ddaccordionmenu for main navigation and animatedcollapse for one of the pages inside the site. Unfortunately, on that one page ddaccordionmenu doesn't work (the open and close icons don't appear and submenus don't open) however the animatedcollapse works fine. Does anyone know if there is a fix for this conflict?


11-10-2009, 05:58 PM
There doesn't appear to be any conflict between the two latest versions for these scripts:

Animated Collapsible DIV v2.4


Accordion Content script (v1.7.1)

Make sure you are using the latest versions of both.

Other than that, you may have introduced a conflict by using the same id or variable name somewhere in the code for initialization and/or markup for these two scripts, or simply made a typo somewhere. Also, since both of these scripts use jQuery 1.3.2, you should only include that script once on the page.

If you want more help:

Please post a link to the page on your site that contains the problematic code so we can check it out.

11-10-2009, 07:10 PM
Of course! Thanks for pointing that out.

Just to clarify I have two references to jquery. Does it make a difference which one I keep. I assume the latest (from Google?).

<script type="text/javascript" src="func-lib/jquery-1.2.2.pack.js"></script>

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>

Thanks for your speedy response!!

11-10-2009, 09:47 PM
You should use:

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>

But if you have jquery-1.2.2, that means that you either are using an older version of one of the scripts, or forgot to remove the reference to jquery-1.2.2 when you upgraded one of the scripts or that you have yet a third script using jquery-1.2.2 - I can't really tell without seeing the page. Though you should know. If you are using an older version of either or both of the scripts, upgrade to the most recent versions. If there is another (third) script that actually needs jquery-1.2.2, it may be difficult though not impossible to work things out.

Most likely though one or the other of the two scripts is out of date. If so, simply remove the reference to jquery-1.2.2 and upgrade the out of date script. The reference to jquery/1.3.2/jquery.min.js should come before both scripts in the head.

Once again, if you want more help:

Please post a link to the page on your site that contains the problematic code so we can check it out.