PDA

View Full Version : stepcarousel Not working period!



proch
09-08-2009, 01:10 PM
1) Script Title: Stepcarousel

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/stepcarousel.htm


3) Describe problem: Step carousel not functioning. I've done what it was required, but when I view it Firebug, it says that stepcarousel is undefined which seems odd.

http://akibavault.com/theImmag/

ddadmin
09-09-2009, 06:50 AM
The two .js references to the script in the HEAD section of your page are broken:


<script type='text/javascript' src='http://akibavault.com/theImmag/wp-content/themes/Immigrantmagazine/library/js/stepcarousel.js?ver=2.8.4'></script>
<script type='text/javascript' src='http://akibavault.com/theImmag/wp-content/themes/Immigrantmagazine/library/js/stepcarousel-setup.js?ver=2.8.4'></script>


For example, if you try to visit one of the referenced files (http://akibavault.com/theImmag/wp-content/themes/Immigrantmagazine/library/js/stepcarousel.js?ver=2.8.4), they take you to a web page instead of the source of the script itself.

proch
09-19-2009, 03:34 AM
Thank you very much.
How do you fix that.

Here is what my head section cod looks like

<?php
wp_enqueue_script('jquery');
wp_enqueue_script( 'stepcarousel', get_bloginfo('template_directory').'/library/js/stepcarousel.js', array('jquery'));
wp_enqueue_script( 'stepcarousel-setup', get_bloginfo('template_directory').'/library/js/stepcarousel-setup.js', array('jquery'));
?>
Please help.
Here is the site address
http://www.akibavault.com

proch
09-19-2009, 09:21 AM
I read others posts regarding broken .js reference file, and I double check where my script was pointing to. Yet, I don't seem to get what the problem may be. I'm not sure if I should include the full path. As you can see on my previous post, the php code looks at the template directory to point the scripts.

Thanks in advance for the help.

ddadmin
09-20-2009, 07:54 AM
Right now the URLs to the external files of Step Carousel on your page are broken, for example:


<script type='text/javascript' src='http://www.immigrantmagazine.com/wp-content/themes/Immigrantmagazine/library/js/stepcarousel.js?ver=2.8.4'></script>
<script type='text/javascript' src='http://www.immigrantmagazine.com/wp-content/themes/Immigrantmagazine/library/js/stepcarousel-setup.js?ver=2.8.4'></script>

If you try to load the first link (http://www.immigrantmagazine.com/wp-content/themes/Immigrantmagazine/library/js/stepcarousel.js?ver=2.8.4) for example, it doesn't load the script but the entire page, most likely because the file doesn't exist. You need to make sure the paths to the two files above are correct.

proch
09-20-2009, 08:24 AM
Thank you very much. I think I figure out what the problem was. I renamed the directory from which the file was located before uploading it to the server. That has caused the problem because I tested it by uploading the original directory and it worked fine. Thank you all... this is a great forum.:)