PDA

View Full Version : https breaks enableshim



George Langley
09-03-2009, 06:13 PM
1) Script Title: ddlevelsmenu.js (v 2.1)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddlevelsmenu/

3) Describe problem: Hi all. Have inherited a soon-to-go-live Joomla! site (v 1.5), which uses the slidemenu module, which in turn uses the above dd script. The site works fine with a regular URL (ie. http://www.thesite.com), until I try to link to a secure page (https://www.thesite.com).

At this point, Firefox (Mac v 3.0.13 and Windows v 3.0.5) and Safari (tested Mac only, v 3.2.3) break the site. The 2 main divs (the header, which includes the menu, and the main content div) suddenly act like iFrames, and try to fit the entire site into each of the divs. This results in 2 sets of scroll bars appearing (one for each div) and of course, doubling the content. It also appears to be loading the main "front" page (which has a different template), rather than the called page and article. Again, this only happens for a https address - the exact same page works fine with http.

I narrowed it down to the enableshim setting. Leave it at "true" and the pages break. But, set it to "false", and the pages work properly everywhere. Note that this includes the page that has a .flv video - the menu still appears on top of the video (it uses the AllVideos plugin, which in turn uses the longtail flv video player).

So, AFAIK, the issue is "fixed", but would like to know if anyone else has run into this, or has a better solution, or if there is a bug that we need to address (in the script, the Joomla! module, possibly even the template the pages use, etc.).

Thanks, and hope this helps someone else. (Will post the site URL as soon as it goes live.)

ddadmin
09-04-2009, 02:00 AM
Not sure if this changes anything, but inside the .js file, did you remember to configure the following property:


httpsiframesrc: "blank.htm", //If menu is run on a secure (https) page, the IFRAME shim feature used by the script should point to an *blank* page *within* the secure area to prevent an IE security prompt. Specify full URL to that page on your server (leave as is if not applicable).

Per the comments, the blank page should be created behind the secure area, with the reference above correctly pointing to it.

George Langley
09-09-2009, 05:55 AM
Hmm, no I did not see that. But as you allude to, not sure it will change anything, as is a FF/Safari issue I ran into, not an IE one. However, will definitely check it out, thanks!