PDA

View Full Version : Jumping Jiminy...smooth navigational script



hugh
07-25-2009, 02:26 AM
Smooth Navigational Menu

http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm

This script works fine and dandy....until I try and remove the sub-menu shadow from the css file. the lines I remove are at the bottom:


/* ######### CSS for shadow added to sub menus ######### */

.ddshadow{
position: absolute;
left: 0;
top: 0;
width: 0;
height: 0;
background: silver;
}


.toplevelshadow{ /*shadow opacity. Doesn't work in IE*/
opacity: 0.8;
}

Remove those lines from the CSS file and as soon as you mouseover a link which has sub-menus, the whole menu system jumps up and down like a demented frog!

I haven't a clue what's going on, I'm only removing some shadow selectors. I don't want shadow effects.

Try it yourselves! I tested in Safari, Firefox and Camino on a Mac and it leaps about on all three.

Hugh

ddadmin
07-27-2009, 09:13 PM
Ah yes there's a bug in the script that prevented shadows from being dismissible. Just redownload ddsmoothmenu.js on the menu page (http://www.dynamicdrive.com/dynamicindex1/ddsmoothmenu.htm), and inside it, set the following variable in red to false:


shadow: {enabled:false, offsetx:5, offsety:5},

hugh
07-27-2009, 11:06 PM
Many thanks for the quick reply. Unfortunately it's still not working.

I downloaded the new .js file and amended the show shadow variable to 'false'. I also deleted the shadow class from the CSS file.

It's still jumping about for me, I'm afraid. :( ...in both Camino and Firefox (Firefox/2.0.0.20)

I have fixed it in a fashion - by setting the offsets in the javascript file to '0' rather than '5'. It's a workaround, but it still looks like there's something wrong in the basic code?

Hugh

ddadmin
07-28-2009, 12:05 AM
Do you have a link to the problem page? You should change the offset back to 5, just so I can see the issue.