PDA

View Full Version : DHTML Window widget (v1.1)



zethkeb
06-11-2009, 02:30 PM
1) Script Title: DHTML Window widget (v1.1)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex8/dhtmlwindow/index.htm

3) Describe problem:

I actually first experienced the problem using:
DHTML Modal window v1.1
http://www.dynamicdrive.com/dynamicindex8/dhtmlwindow/dhtmlmodal.htm

I'm writing an XSLT that renders XML as HTML on the client side.
Here's the XSLT snipit


<?xml version="1.0"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:template match="/">
<html>
<head>
<link rel="stylesheet" href="/utility/modaldialog/windowfiles/dhtmlwindow.css" type="text/css" />
<script type="text/javascript" src="/utility/modaldialog/windowfiles/dhtmlwindow.js">
<![CDATA[/***********************************************
* DHTML Window Widget- Dynamic Drive (www.dynamicdrive.com)
* This notice must stay intact for legal use.
* Visit http://www.dynamicdrive.com/ for full source code
***********************************************]]>
</script>
<link rel="stylesheet" href="utility/modaldialog/modalfiles/modal.css" type="text/css" />
<script type="text/javascript" src="/utility/modaldialog/modalfiles/modal.js"></script>
<script type='text/javascript' src='info.js'></script>
<link rel='stylesheet' href='info.css' type='text/css' />
</head>
<body>
<table.....

</table>
</body>
</html>
</xsl:template>
</xsl:stylesheet>


If I pull the script out of the XSLT, the page loads fine. when I add the script under the Modal Window script I get a popup that says the Windows script is required. If I just add the windows script, the page continues to load without stopping. If I do stop it, I get a div element returned and nothing else.

Firefox

<div id="dhtmlwindowholder"><span style="display:none">.</span></div>

IE

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

An invalid character was found in text content. Error processing resource 'http://services.wdwinfo.com/poi/info/fastpass.xs...

* DHTML Window Widget-




Please Help

zethkeb
06-12-2009, 04:23 AM
I deleted the copyright text (just for testing purposes) and it solved the IE problem (the site now works successfully in IE) but Firefox still returns the empty div when executing ;(

This is a great script and it works perfectly in an HTML file. If I can just get past this one (and figure out how to do it without violating copyright) I'll be a happy camper

ddadmin
06-12-2009, 04:34 AM
Hmmm please post a link to the page on your site that contains the problematic script so we can check it out.

zethkeb
06-12-2009, 12:44 PM
http://services.wdwinfo.com/poi/info?read&output=html&poi_id=287

XSLT can be downloaded at
http://services.wdwinfo.com/poi/info/fastpass.xsl