PDA

View Full Version : RESOLVED - Multi uses a Crawler script in slidebox - problem



Master79
05-14-2009, 07:27 AM
1) Script Title: Text and Image Crawler

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex2/crawler/index.htm

3) Describe problem: I have small(big) problem to use a many crawler at the same time on my site http://www.play-esports.pl/index.php?mod=news&action=recent&lang=English -> left panel TEAM ROOSTER... when i open first time my browser and go to my site ... script stops and have a error in line 207


while(this.c.offsetWidth > this.w - s)
this.c.style.width = isNaN(this.cw[0])? this.w - s + 'px' : --this.cw[0] + this.cw[1];
this.c.style.visibility = 'visible';

when i refresh site on browser everything is ok , script work on all squads(slides) ...

All slides with squads have code with crawler script and i change for next slides

<div id="squads_slider" .... <div id="squads_slider1"
uniqueid: 'squads_slider' ... uniqueid: 'squads_slider1',



<div class="squads_slider" id="squads_slider1" style="float:center ; padding-top: 3px">
{loop:squads}
<a href="{squads:link}" title="{squads:nick}">{squads:picture}</a>
{stop:squads}
</div>

......
......

<script type="text/javascript">

marqueeInit({
uniqueid: 'squads_slider1',
style: {
'width': '220px',
'height': '110px'
},
inc: 3, //speed - pixel increment for each iteration of this marquee's movement
mouse: 'cursor driven', //mouseover behavior ('pause' 'cursor driven' or false)
moveatleast: 1,
neutral: 140,
savedirection: true
});
</script>



i don't know what could be wrong at first start of script, it is possible to fix it ?

I change slidebox script and now clawer scripts works ok